aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-02-05 17:14:17 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-02-17 15:21:46 +0000
commit58b82e6ca503aea3f67b4692f2c3196cb0a2ca2c (patch)
treea632ebec6adbc74187badde0c619561a7ec0465e /target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch
parent397de500896f3c7c4e2468c21521502392af4574 (diff)
downloadupstream-58b82e6ca503aea3f67b4692f2c3196cb0a2ca2c.tar.gz
upstream-58b82e6ca503aea3f67b4692f2c3196cb0a2ca2c.tar.bz2
upstream-58b82e6ca503aea3f67b4692f2c3196cb0a2ca2c.zip
realtek: drop support for Linux 5.4
Drop patches and files for Linux 5.4 now that we've been using 5.10 for a while and support for Linux 5.4 has gone out-of-sync. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch')
-rw-r--r--target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch34
1 files changed, 0 insertions, 34 deletions
diff --git a/target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch b/target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch
deleted file mode 100644
index db8f22bf02..0000000000
--- a/target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- a/drivers/clocksource/Kconfig
-+++ b/drivers/clocksource/Kconfig
-@@ -128,6 +128,15 @@ config RDA_TIMER
- help
- Enables the support for the RDA Micro timer driver.
-
-+config RTL9300_TIMER
-+ bool "Clocksource/timer for the Realtek RTL9300 family of SoCs"
-+ depends on MIPS
-+ select COMMON_CLK
-+ select TIMER_OF
-+ select CLKSRC_MMIO
-+ help
-+ Enables support for the Realtek RTL9300 timer driver.
-+
- config SUN4I_TIMER
- bool "Sun4i timer driver" if COMPILE_TEST
- depends on HAS_IOMEM
-@@ -697,5 +706,4 @@ config INGENIC_TIMER
- select IRQ_DOMAIN
- help
- Support for the timer/counter unit of the Ingenic JZ SoCs.
--
- endmenu
---- a/drivers/clocksource/Makefile
-+++ b/drivers/clocksource/Makefile
-@@ -61,6 +61,7 @@ obj-$(CONFIG_MILBEAUT_TIMER) += timer-mi
- obj-$(CONFIG_SPRD_TIMER) += timer-sprd.o
- obj-$(CONFIG_NPCM7XX_TIMER) += timer-npcm7xx.o
- obj-$(CONFIG_RDA_TIMER) += timer-rda.o
-+obj-$(CONFIG_RTL9300_TIMER) += timer-rtl9300.o
-
- obj-$(CONFIG_ARC_TIMERS) += arc_timer.o
- obj-$(CONFIG_ARM_ARCH_TIMER) += arm_arch_timer.o