aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.4/301-gpio-add-rtl838x-driver.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-11-26 12:02:21 +0100
committerJohn Crispin <john@phrozen.org>2020-11-26 13:29:27 +0100
commit2b88563ee5aafd9571d965b7f2093a0f58d98a31 (patch)
treed2997a6745fe0cffab8db73d4a735c3366a301b0 /target/linux/realtek/patches-5.4/301-gpio-add-rtl838x-driver.patch
parent4e39949dd1f7eb706d857e1c44a992ae752132a7 (diff)
downloadupstream-2b88563ee5aafd9571d965b7f2093a0f58d98a31.tar.gz
upstream-2b88563ee5aafd9571d965b7f2093a0f58d98a31.tar.bz2
upstream-2b88563ee5aafd9571d965b7f2093a0f58d98a31.zip
realtek: update the tree to the latest refactored version
* rename the target to realtek * add refactored DSA driver * add latest gpio driver * lots of arch cleanups * new irq driver * additional boards Signed-off-by: Bert Vermeulen <bert@biot.com> Signed-off-by: Birger Koblitz <mail@birger-koblitz.de> Signed-off-by: Sander Vanheule <sander@svanheule.net> Signed-off-by: Bjørn Mork <bjorn@mork.no> Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/realtek/patches-5.4/301-gpio-add-rtl838x-driver.patch')
-rw-r--r--target/linux/realtek/patches-5.4/301-gpio-add-rtl838x-driver.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/realtek/patches-5.4/301-gpio-add-rtl838x-driver.patch b/target/linux/realtek/patches-5.4/301-gpio-add-rtl838x-driver.patch
new file mode 100644
index 0000000000..4f5901d87f
--- /dev/null
+++ b/target/linux/realtek/patches-5.4/301-gpio-add-rtl838x-driver.patch
@@ -0,0 +1,32 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -441,6 +441,18 @@ config GPIO_REG
+ A 32-bit single register GPIO fixed in/out implementation. This
+ can be used to represent any register as a set of GPIO signals.
+
++config GPIO_RTL8231
++ tristate "RTL8231 GPIO"
++ depends on GPIO_RTL838X
++ help
++ Say yes here to support Realtek RTL8231 GPIO expansion chips.
++
++config GPIO_RTL838X
++ tristate "RTL838X GPIO"
++ depends on RTL838X
++ help
++ Say yes here to support RTL838X GPIO devices.
++
+ config GPIO_SAMA5D2_PIOBU
+ tristate "SAMA5D2 PIOBU GPIO support"
+ depends on MFD_SYSCON
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -117,6 +117,8 @@ obj-$(CONFIG_GPIO_RC5T583) += gpio-rc5t
+ obj-$(CONFIG_GPIO_RCAR) += gpio-rcar.o
+ obj-$(CONFIG_GPIO_RDC321X) += gpio-rdc321x.o
+ obj-$(CONFIG_GPIO_REG) += gpio-reg.o
++obj-$(CONFIG_GPIO_RTL8231) += gpio-rtl8231.o
++obj-$(CONFIG_GPIO_RTL838X) += gpio-rtl838x.o
+ obj-$(CONFIG_ARCH_SA1100) += gpio-sa1100.o
+ obj-$(CONFIG_GPIO_SAMA5D2_PIOBU) += gpio-sama5d2-piobu.o
+ obj-$(CONFIG_GPIO_SCH311X) += gpio-sch311x.o