aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.15
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2022-12-29 11:27:54 +0100
committerSander Vanheule <sander@svanheule.net>2023-01-28 17:31:12 +0100
commitf6ba61b9298f12dbf116556edc879d047e5145e9 (patch)
tree4084d6b114c19fcda0f4283fbe4111f4a70cbfec /target/linux/realtek/patches-5.15
parent68e28cdc47ac805faf2dda58127e848f8ef6efca (diff)
downloadupstream-f6ba61b9298f12dbf116556edc879d047e5145e9.tar.gz
upstream-f6ba61b9298f12dbf116556edc879d047e5145e9.tar.bz2
upstream-f6ba61b9298f12dbf116556edc879d047e5145e9.zip
realtek: timer: Remove CEVT_RTL9300 completely
As the timer has been fixed now, we can drop the CEVT_RTL9300 timer all together. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'target/linux/realtek/patches-5.15')
-rw-r--r--target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch10
-rw-r--r--target/linux/realtek/patches-5.15/309-cevt-rtl9300-support.patch54
2 files changed, 0 insertions, 64 deletions
diff --git a/target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch b/target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch
index 4027b5319a..6407a49fb6 100644
--- a/target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch
+++ b/target/linux/realtek/patches-5.15/300-mips-add-rtl838x-platform.patch
@@ -84,13 +84,3 @@ Submitted-by: Birger Koblitz <git@birger-koblitz.de>
source "arch/mips/alchemy/Kconfig"
source "arch/mips/ath25/Kconfig"
source "arch/mips/ath79/Kconfig"
-@@ -1112,6 +1162,9 @@ config CEVT_GT641XX
- config CEVT_R4K
- bool
-
-+config CEVT_RTL9300
-+ bool
-+
- config CEVT_SB1250
- bool
-
diff --git a/target/linux/realtek/patches-5.15/309-cevt-rtl9300-support.patch b/target/linux/realtek/patches-5.15/309-cevt-rtl9300-support.patch
deleted file mode 100644
index 93d69c07cf..0000000000
--- a/target/linux/realtek/patches-5.15/309-cevt-rtl9300-support.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 775d903216a08c2a8009863d2f9c33f62657ba94 Mon Sep 17 00:00:00 2001
-From: Birger Koblitz <git@birger-koblitz.de>
-Date: Thu, 6 Jan 2022 20:27:01 +0100
-Subject: [PATCH] realtek: Replace the RTL9300 generic timer with a CEVT timer
-
-The RTL9300 has a broken R4K MIPS timer interrupt, however, the
-R4K clocksource works. We replace the RTL9300 timer with a
-Clock Event Timer (CEVT), which is VSMP aware and can be instantiated
-as part of brining a VSMTP cpu up instead of the R4K CEVT source.
-For this we place the RTL9300 CEVT timer in arch/mips/kernel
-together with other MIPS CEVT timers, initialize the SoC IRQs
-from a modified smp-mt.c and instantiate each timer as part
-of the MIPS time setup in arch/mips/include/asm/time.h instead
-of the R4K CEVT, similarly as is done by other MIPS CEVT timers.
-
-Submitted-by: Birger Koblitz <git@birger-koblitz.de>
----
- arch/mips/kernel/Makefile | 1 +
- arch/mips/include/asm/time.h | 7 +++++++
- 2 files changed, 8 insertions(+)
-
---- a/arch/mips/kernel/Makefile
-+++ b/arch/mips/kernel/Makefile
-@@ -27,6 +27,7 @@ obj-$(CONFIG_CEVT_BCM1480) += cevt-bcm14
- obj-$(CONFIG_CEVT_R4K) += cevt-r4k.o
- obj-$(CONFIG_CEVT_DS1287) += cevt-ds1287.o
- obj-$(CONFIG_CEVT_GT641XX) += cevt-gt641xx.o
-+obj-$(CONFIG_CEVT_RTL9300) += cevt-rtl9300.o
- obj-$(CONFIG_CEVT_SB1250) += cevt-sb1250.o
- obj-$(CONFIG_CEVT_TXX9) += cevt-txx9.o
- obj-$(CONFIG_CSRC_BCM1480) += csrc-bcm1480.o
---- a/arch/mips/include/asm/time.h
-+++ b/arch/mips/include/asm/time.h
-@@ -15,6 +15,8 @@
- #include <linux/clockchips.h>
- #include <linux/clocksource.h>
-
-+extern void rtl9300_clockevent_init(void);
-+
- extern spinlock_t rtc_lock;
-
- /*
-@@ -43,6 +45,11 @@ extern int r4k_clockevent_init(void);
-
- static inline int mips_clockevent_init(void)
- {
-+#ifdef CONFIG_CEVT_RTL9300
-+ rtl9300_clockevent_init();
-+ return 0;
-+#endif
-+
- #ifdef CONFIG_CEVT_R4K
- return r4k_clockevent_init();
- #else