aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.10
diff options
context:
space:
mode:
authorBirger Koblitz <git@birger-koblitz.de>2022-02-11 08:19:19 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-02-17 15:21:46 +0000
commit48dd4466147de7b1f143c42d23fa4d4780496f40 (patch)
tree49cc3ada47051a08eaa7359f902843a08af6c6ff /target/linux/realtek/patches-5.10
parent2314ba725b2b33cd679d46eba42b73f854427632 (diff)
downloadupstream-48dd4466147de7b1f143c42d23fa4d4780496f40.tar.gz
upstream-48dd4466147de7b1f143c42d23fa4d4780496f40.tar.bz2
upstream-48dd4466147de7b1f143c42d23fa4d4780496f40.zip
realtek: remove legacy GPIO driver support
This patch removes support for the legacy GPIO driver, since now the gpio-otto driver can be used on all platforms Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
Diffstat (limited to 'target/linux/realtek/patches-5.10')
-rw-r--r--target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch b/target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch
deleted file mode 100644
index 1ea8add32b..0000000000
--- a/target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/drivers/gpio/Kconfig
-+++ b/drivers/gpio/Kconfig
-@@ -514,6 +514,12 @@ config GPIO_RTL8231
- help
- Say yes here to support Realtek RTL8231 GPIO expansion chips.
-
-+config GPIO_RTL838X
-+ tristate "RTL838X GPIO"
-+ depends on RTL838X
-+ help
-+ Say yes here to support RTL838X GPIO on RTL93xx SoCs.
-+
- config GPIO_SAMA5D2_PIOBU
- tristate "SAMA5D2 PIOBU GPIO support"
- depends on MFD_SYSCON
---- a/drivers/gpio/Makefile
-+++ b/drivers/gpio/Makefile
-@@ -127,6 +127,7 @@ obj-$(CONFIG_GPIO_RDC321X) += gpio-rdc3
- obj-$(CONFIG_GPIO_REALTEK_OTTO) += gpio-realtek-otto.o
- obj-$(CONFIG_GPIO_REG) += gpio-reg.o
- obj-$(CONFIG_GPIO_RTL8231) += gpio-rtl8231.o
-+obj-$(CONFIG_GPIO_RTL838X) += gpio-rtl838x.o
- obj-$(CONFIG_ARCH_SA1100) += gpio-sa1100.o
- obj-$(CONFIG_GPIO_SAMA5D2_PIOBU) += gpio-sama5d2-piobu.o
- obj-$(CONFIG_GPIO_SCH311X) += gpio-sch311x.o