aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.10
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2021-06-24 20:32:31 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-09-26 00:32:17 +0200
commitfbd675c668e1e6be4e5a8a8107902282e668a3a0 (patch)
tree976aa13dfce0afd9eb9835906ff28e365a34def7 /target/linux/realtek/patches-5.10
parent0b000cbfe0aa0323bffa855ef8449c0687a4c071 (diff)
downloadupstream-fbd675c668e1e6be4e5a8a8107902282e668a3a0.tar.gz
upstream-fbd675c668e1e6be4e5a8a8107902282e668a3a0.tar.bz2
upstream-fbd675c668e1e6be4e5a8a8107902282e668a3a0.zip
realtek: drop rtl838x gpio driver from 5.10
To backport the upstreamed driver (gpio-realtek-otto) from 5.13, drop the old driver from realtek target. And, modify 301-gpio-add-rtl838x-driver.patch to remove rtl838x GPIO support and rename it only for rtl8231 GPIO support. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/realtek/patches-5.10')
-rw-r--r--target/linux/realtek/patches-5.10/301-gpio-add-rtl8231-driver.patch (renamed from target/linux/realtek/patches-5.10/301-gpio-add-rtl838x-driver.patch)13
1 files changed, 3 insertions, 10 deletions
diff --git a/target/linux/realtek/patches-5.10/301-gpio-add-rtl838x-driver.patch b/target/linux/realtek/patches-5.10/301-gpio-add-rtl8231-driver.patch
index 4f5901d87f..8a3d4810a6 100644
--- a/target/linux/realtek/patches-5.10/301-gpio-add-rtl838x-driver.patch
+++ b/target/linux/realtek/patches-5.10/301-gpio-add-rtl8231-driver.patch
@@ -1,32 +1,25 @@
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
-@@ -441,6 +441,18 @@ config GPIO_REG
+@@ -441,6 +441,12 @@ config GPIO_REG
A 32-bit single register GPIO fixed in/out implementation. This
can be used to represent any register as a set of GPIO signals.
+config GPIO_RTL8231
+ tristate "RTL8231 GPIO"
-+ depends on GPIO_RTL838X
-+ help
-+ Say yes here to support Realtek RTL8231 GPIO expansion chips.
-+
-+config GPIO_RTL838X
-+ tristate "RTL838X GPIO"
+ depends on RTL838X
+ help
-+ Say yes here to support RTL838X GPIO devices.
++ Say yes here to support Realtek RTL8231 GPIO expansion chips.
+
config GPIO_SAMA5D2_PIOBU
tristate "SAMA5D2 PIOBU GPIO support"
depends on MFD_SYSCON
--- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile
-@@ -117,6 +117,8 @@ obj-$(CONFIG_GPIO_RC5T583) += gpio-rc5t
+@@ -117,6 +117,7 @@ obj-$(CONFIG_GPIO_RC5T583) += gpio-rc5t
obj-$(CONFIG_GPIO_RCAR) += gpio-rcar.o
obj-$(CONFIG_GPIO_RDC321X) += gpio-rdc321x.o
obj-$(CONFIG_GPIO_REG) += gpio-reg.o
+obj-$(CONFIG_GPIO_RTL8231) += gpio-rtl8231.o
-+obj-$(CONFIG_GPIO_RTL838X) += gpio-rtl838x.o
obj-$(CONFIG_ARCH_SA1100) += gpio-sa1100.o
obj-$(CONFIG_GPIO_SAMA5D2_PIOBU) += gpio-sama5d2-piobu.o
obj-$(CONFIG_GPIO_SCH311X) += gpio-sch311x.o