aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.10
diff options
context:
space:
mode:
authorJohn Audia <graysky@archlinux.us>2021-10-09 12:22:14 -0400
committerDaniel Golle <daniel@makrotopia.org>2021-10-10 00:09:22 +0100
commite672d1b387604b71058b5c9edc9234fc7efebb25 (patch)
tree825466d4e3e55f18d2c9edcfe6a85c1a1a1c0e80 /target/linux/realtek/patches-5.10
parent20bc4507714fbc5dfbe3632afeb260b071591acb (diff)
downloadupstream-e672d1b387604b71058b5c9edc9234fc7efebb25.tar.gz
upstream-e672d1b387604b71058b5c9edc9234fc7efebb25.tar.bz2
upstream-e672d1b387604b71058b5c9edc9234fc7efebb25.zip
kernel: bump 5.10 to 5.10.72
All patches automatically rebased. Build system: x86_64 Build-tested: bcm2711/RPi4B Run-tested: bcm2711/RPi4B Signed-off-by: John Audia <graysky@archlinux.us>
Diffstat (limited to 'target/linux/realtek/patches-5.10')
-rw-r--r--target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch4
-rw-r--r--target/linux/realtek/patches-5.10/704-include-linux-add-phy-hsgmii-mode.patch8
-rw-r--r--target/linux/realtek/patches-5.10/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch2
3 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch b/target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch
index 830440cf8d..1ea8add32b 100644
--- a/target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch
+++ b/target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
-@@ -514,6 +514,12 @@
+@@ -514,6 +514,12 @@ config GPIO_RTL8231
help
Say yes here to support Realtek RTL8231 GPIO expansion chips.
@@ -15,7 +15,7 @@
depends on MFD_SYSCON
--- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile
-@@ -127,6 +127,7 @@
+@@ -127,6 +127,7 @@ obj-$(CONFIG_GPIO_RDC321X) += gpio-rdc3
obj-$(CONFIG_GPIO_REALTEK_OTTO) += gpio-realtek-otto.o
obj-$(CONFIG_GPIO_REG) += gpio-reg.o
obj-$(CONFIG_GPIO_RTL8231) += gpio-rtl8231.o
diff --git a/target/linux/realtek/patches-5.10/704-include-linux-add-phy-hsgmii-mode.patch b/target/linux/realtek/patches-5.10/704-include-linux-add-phy-hsgmii-mode.patch
index 9a61a70c44..d47e7bad50 100644
--- a/target/linux/realtek/patches-5.10/704-include-linux-add-phy-hsgmii-mode.patch
+++ b/target/linux/realtek/patches-5.10/704-include-linux-add-phy-hsgmii-mode.patch
@@ -1,15 +1,15 @@
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -93,6 +93,7 @@
- PHY_INTERFACE_MODE_SMII,
+@@ -133,6 +133,7 @@ typedef enum {
PHY_INTERFACE_MODE_XGMII,
+ PHY_INTERFACE_MODE_XLGMII,
PHY_INTERFACE_MODE_MOCA,
+ PHY_INTERFACE_MODE_HSGMII,
PHY_INTERFACE_MODE_QSGMII,
PHY_INTERFACE_MODE_TRGMII,
PHY_INTERFACE_MODE_1000BASEX,
-@@ -163,6 +164,8 @@
- return "xgmii";
+@@ -199,6 +200,8 @@ static inline const char *phy_modes(phy_
+ return "xlgmii";
case PHY_INTERFACE_MODE_MOCA:
return "moca";
+ case PHY_INTERFACE_MODE_HSGMII:
diff --git a/target/linux/realtek/patches-5.10/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch b/target/linux/realtek/patches-5.10/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch
index d36299d43b..64e6b5d309 100644
--- a/target/linux/realtek/patches-5.10/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch
+++ b/target/linux/realtek/patches-5.10/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch
@@ -1,6 +1,6 @@
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -226,7 +226,7 @@ static inline const char *phy_modes(phy_
+@@ -229,7 +229,7 @@ static inline const char *phy_modes(phy_
#define PHY_INIT_TIMEOUT 100000
#define PHY_FORCE_TIMEOUT 10