aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.10
diff options
context:
space:
mode:
authorBirger Koblitz <git@birger-koblitz.de>2021-09-27 20:57:29 +0200
committerJohn Crispin <john@phrozen.org>2021-10-09 08:25:06 +0200
commitcda0460ad333f15e15ec9bd2516b2ae45f8a4644 (patch)
tree23e150a5e825f65c55c527a4c90668e4f1b71644 /target/linux/realtek/patches-5.10
parent4c83dae801a83fdfc07fce8aa68978839a76ae02 (diff)
downloadupstream-cda0460ad333f15e15ec9bd2516b2ae45f8a4644.tar.gz
upstream-cda0460ad333f15e15ec9bd2516b2ae45f8a4644.tar.bz2
upstream-cda0460ad333f15e15ec9bd2516b2ae45f8a4644.zip
realtek: add legacy realtek GPIO driver for rtl9300 support
The otto GPIO driver does not work with rtl9300 SoCs. Add the legacy driver again and use that by default in the 9300 .dtsi Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
Diffstat (limited to 'target/linux/realtek/patches-5.10')
-rw-r--r--target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch b/target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch
new file mode 100644
index 0000000000..830440cf8d
--- /dev/null
+++ b/target/linux/realtek/patches-5.10/306-gpio-add-legacy-rtl838x-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -514,6 +514,12 @@
+ help
+ Say yes here to support Realtek RTL8231 GPIO expansion chips.
+
++config GPIO_RTL838X
++ tristate "RTL838X GPIO"
++ depends on RTL838X
++ help
++ Say yes here to support RTL838X GPIO on RTL93xx SoCs.
++
+ config GPIO_SAMA5D2_PIOBU
+ tristate "SAMA5D2 PIOBU GPIO support"
+ depends on MFD_SYSCON
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -127,6 +127,7 @@
+ obj-$(CONFIG_GPIO_REALTEK_OTTO) += gpio-realtek-otto.o
+ obj-$(CONFIG_GPIO_REG) += gpio-reg.o
+ obj-$(CONFIG_GPIO_RTL8231) += gpio-rtl8231.o
++obj-$(CONFIG_GPIO_RTL838X) += gpio-rtl838x.o
+ obj-$(CONFIG_ARCH_SA1100) += gpio-sa1100.o
+ obj-$(CONFIG_GPIO_SAMA5D2_PIOBU) += gpio-sama5d2-piobu.o
+ obj-$(CONFIG_GPIO_SCH311X) += gpio-sch311x.o