aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.10
diff options
context:
space:
mode:
authorJohn Audia <graysky@archlinux.us>2021-11-26 08:29:01 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-27 19:19:30 +0100
commit894f483d203a34618a3c725c808b8811d69c4430 (patch)
treef41f05cf32121486bae9b26bf510251a682ef6de /target/linux/realtek/patches-5.10
parentbe077f48124b8bcedd7cdb552c050ce73a42e509 (diff)
downloadupstream-894f483d203a34618a3c725c808b8811d69c4430.tar.gz
upstream-894f483d203a34618a3c725c808b8811d69c4430.tar.bz2
upstream-894f483d203a34618a3c725c808b8811d69c4430.zip
kernel: bump 5.10 to 5.10.82
Removed upstreamed: bcm53xx/patches-5.10/033-v5.16-0014-ARM-dts-NSP-Fix-mpcore-mmc-node-names.patch Manually rebased: ipq806x/patches-5.10/086-ipq8064-fix-duplicate-node.patch All other patches automatically rebased. Build system: x86_64 Build-tested: bcm2711/RPi4B, ipq806x/R7800 Run-tested: bcm2711/RPi4B, ipq806x/R7800 Signed-off-by: John Audia <graysky@archlinux.us>
Diffstat (limited to 'target/linux/realtek/patches-5.10')
-rw-r--r--target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch18
-rw-r--r--target/linux/realtek/patches-5.10/300-mips-add-rtl838x-platform.patch2
-rw-r--r--target/linux/realtek/patches-5.10/307-wdt-update-dependency-for-realtek-otto-wdt.patch6
-rw-r--r--target/linux/realtek/patches-5.10/308-otto-wdt-fix-missing-math-header.patch6
4 files changed, 8 insertions, 24 deletions
diff --git a/target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch b/target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch
index 5aa988dc55..fae478a624 100644
--- a/target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch
+++ b/target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch
@@ -30,11 +30,9 @@ Signed-off-by: Sander Vanheule <sander@svanheule.net>
4 files changed, 382 insertions(+)
create mode 100644 drivers/watchdog/realtek_otto_wdt.c
-diff --git a/MAINTAINERS b/MAINTAINERS
-index 2c9070aeba2a..54c8f788d3e5 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
-@@ -15991,6 +15991,13 @@ S: Maintained
+@@ -14815,6 +14815,13 @@ S: Maintained
F: include/sound/rt*.h
F: sound/soc/codecs/rt*
@@ -48,11 +46,9 @@ index 2c9070aeba2a..54c8f788d3e5 100644
REALTEK RTL83xx SMI DSA ROUTER CHIPS
M: Linus Walleij <linus.walleij@linaro.org>
S: Maintained
-diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig
-index bf59faeb3de1..d308e13a9aa1 100644
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
-@@ -954,6 +954,19 @@ config RTD119X_WATCHDOG
+@@ -995,6 +995,19 @@ config RTD119X_WATCHDOG
Say Y here to include support for the watchdog timer in
Realtek RTD1295 SoCs.
@@ -72,11 +68,9 @@ index bf59faeb3de1..d308e13a9aa1 100644
config SPRD_WATCHDOG
tristate "Spreadtrum watchdog support"
depends on ARCH_SPRD || COMPILE_TEST
-diff --git a/drivers/watchdog/Makefile b/drivers/watchdog/Makefile
-index 1bd2d6f37c53..a8dccf819163 100644
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
-@@ -171,6 +171,7 @@ obj-$(CONFIG_IMGPDC_WDT) += imgpdc_wdt.o
+@@ -174,6 +174,7 @@ obj-$(CONFIG_IMGPDC_WDT) += imgpdc_wdt.o
obj-$(CONFIG_MT7621_WDT) += mt7621_wdt.o
obj-$(CONFIG_PIC32_WDT) += pic32-wdt.o
obj-$(CONFIG_PIC32_DMT) += pic32-dmt.o
@@ -84,9 +78,6 @@ index 1bd2d6f37c53..a8dccf819163 100644
# PARISC Architecture
-diff --git a/drivers/watchdog/realtek_otto_wdt.c b/drivers/watchdog/realtek_otto_wdt.c
-new file mode 100644
-index 000000000000..48bc8dfefc25
--- /dev/null
+++ b/drivers/watchdog/realtek_otto_wdt.c
@@ -0,0 +1,361 @@
@@ -451,6 +442,3 @@ index 000000000000..48bc8dfefc25
+MODULE_LICENSE("GPL v2");
+MODULE_AUTHOR("Sander Vanheule <sander@svanheule.net>");
+MODULE_DESCRIPTION("Realtek Otto watchdog timer driver");
---
-2.31.1
-
diff --git a/target/linux/realtek/patches-5.10/300-mips-add-rtl838x-platform.patch b/target/linux/realtek/patches-5.10/300-mips-add-rtl838x-platform.patch
index d37b32a274..291636ce7b 100644
--- a/target/linux/realtek/patches-5.10/300-mips-add-rtl838x-platform.patch
+++ b/target/linux/realtek/patches-5.10/300-mips-add-rtl838x-platform.patch
@@ -10,7 +10,7 @@
platform-$(CONFIG_SGI_IP28) += sgi-ip22/
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -629,6 +629,26 @@ config RALINK
+@@ -632,6 +632,26 @@ config RALINK
select ARCH_HAS_RESET_CONTROLLER
select RESET_CONTROLLER
diff --git a/target/linux/realtek/patches-5.10/307-wdt-update-dependency-for-realtek-otto-wdt.patch b/target/linux/realtek/patches-5.10/307-wdt-update-dependency-for-realtek-otto-wdt.patch
index 32c3e2bb69..f4496ed294 100644
--- a/target/linux/realtek/patches-5.10/307-wdt-update-dependency-for-realtek-otto-wdt.patch
+++ b/target/linux/realtek/patches-5.10/307-wdt-update-dependency-for-realtek-otto-wdt.patch
@@ -1,7 +1,5 @@
-Index: linux-5.10.76/drivers/watchdog/Kconfig
-===================================================================
---- linux-5.10.76.orig/drivers/watchdog/Kconfig
-+++ linux-5.10.76/drivers/watchdog/Kconfig
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
@@ -997,10 +997,10 @@ config RTD119X_WATCHDOG
config REALTEK_OTTO_WDT
diff --git a/target/linux/realtek/patches-5.10/308-otto-wdt-fix-missing-math-header.patch b/target/linux/realtek/patches-5.10/308-otto-wdt-fix-missing-math-header.patch
index 20f86ed7e2..0fb61b9df5 100644
--- a/target/linux/realtek/patches-5.10/308-otto-wdt-fix-missing-math-header.patch
+++ b/target/linux/realtek/patches-5.10/308-otto-wdt-fix-missing-math-header.patch
@@ -1,7 +1,5 @@
-Index: linux-5.10.72/drivers/watchdog/realtek_otto_wdt.c
-===================================================================
---- linux-5.10.72.orig/drivers/watchdog/realtek_otto_wdt.c
-+++ linux-5.10.72/drivers/watchdog/realtek_otto_wdt.c
+--- a/drivers/watchdog/realtek_otto_wdt.c
++++ b/drivers/watchdog/realtek_otto_wdt.c
@@ -21,7 +21,7 @@
#include <linux/delay.h>
#include <linux/interrupt.h>