aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image
diff options
context:
space:
mode:
authorSander Vanheule <sander@svanheule.net>2022-07-28 15:13:52 +0200
committerSander Vanheule <sander@svanheule.net>2022-07-28 15:17:04 +0200
commita63aeaecf1f3387df020854c9b22a365207399ce (patch)
treeef6c7197c70e8c5c6847af25ff282da71f322527 /target/linux/realtek/image
parentf2f09bc00280f5bd60b36d525a5e229550958b6d (diff)
downloadupstream-a63aeaecf1f3387df020854c9b22a365207399ce.tar.gz
upstream-a63aeaecf1f3387df020854c9b22a365207399ce.tar.bz2
upstream-a63aeaecf1f3387df020854c9b22a365207399ce.zip
realtek: remove support for HPE 1920 series
Support for HPE 1920 images depends on two non-existent tools (mkh3cimg and mkh3cvfs) from the in the firmware-utils package. Revert commit f2f09bc00280 ("realtek: add support for HPE 1920 series") until support for these tools is merged and made available in OpenWrt. Signed-off-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'target/linux/realtek/image')
-rw-r--r--target/linux/realtek/image/Makefile49
-rw-r--r--target/linux/realtek/image/rtl838x.mk24
2 files changed, 0 insertions, 73 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 6165d99bfc..cf779002e8 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -8,7 +8,6 @@ KERNEL_ENTRY = 0x80000400
DEVICE_VARS += ZYXEL_VERS DLINK_KERNEL_PART_SIZE
DEVICE_VARS += CAMEO_KERNEL_PART CAMEO_ROOTFS_PART CAMEO_CUSTOMER_SIGNATURE CAMEO_BOARD_VERSION
-DEVICE_VARS += H3C_PRODUCT_ID H3C_DEVICE_ID
define Build/zyxel-vers
( echo VERS;\
@@ -42,43 +41,6 @@ define Build/dlink-headers
cat $@.kernel_part.hex $@.rootfs_part.hex > $@
endef
-define Build/7z
- $(STAGING_DIR_HOST)/bin/7zr a $(@).new -t7z -m0=lzma $(@)
- mv $@.new $@
-endef
-
-define Build/h3c-image
- $(STAGING_DIR_HOST)/bin/mkh3cimg \
- -i $(@) \
- -o $(@).new \
- -c 7z \
- -p $(H3C_PRODUCT_ID) \
- -d $(H3C_DEVICE_ID)
- mv $@.new $@
-endef
-
-define Build/h3c-vfs
- $(STAGING_DIR_HOST)/bin/mkh3cvfs \
- -i $(@) \
- -o $(@).new \
- -f openwrt-kernel.bin
- mv $@.new $@
-endef
-
-define Build/relocate-kernel
- rm -rf $@.relocate
- $(CP) ../../generic/image/relocate $@.relocate
- $(MAKE) -j1 -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) LZMA_TEXT_START=0x82000000 \
- CROSS_COMPILE=$(TARGET_CROSS)
- ( \
- dd if=$@.relocate/loader.bin bs=32 conv=sync && \
- perl -e '@s = stat("$@"); print pack("N", @s[7])' && \
- cat "$@" \
- ) > "$@.new"
- mv "$@.new" "$@"
- rm -rf $@.relocate
-endef
-
define Device/Default
PROFILES = Default
KERNEL := kernel-bin | append-dtb | gzip | uImage gzip
@@ -90,17 +52,6 @@ define Device/Default
check-size | append-metadata
endef
-define Device/hpe_1920
- DEVICE_VENDOR := HPE
- IMAGE_SIZE := 29632k
- BLOCKSIZE := 64k
- H3C_PRODUCT_ID := 0x3c010501
- KERNEL := kernel-bin | append-dtb | relocate-kernel | 7z | h3c-image | h3c-vfs
- KERNEL_INITRAMFS := kernel-bin | append-dtb | relocate-kernel | 7z | h3c-image
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
- pad-rootfs | check-size | append-metadata
-endef
-
# "NGE" refers to the uImage magic
define Device/netgear_nge
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
diff --git a/target/linux/realtek/image/rtl838x.mk b/target/linux/realtek/image/rtl838x.mk
index 60eda5359d..887f82e385 100644
--- a/target/linux/realtek/image/rtl838x.mk
+++ b/target/linux/realtek/image/rtl838x.mk
@@ -65,30 +65,6 @@ define Device/engenius_ews2910p
endef
TARGET_DEVICES += engenius_ews2910p
-define Device/hpe_1920-8g
- $(Device/hpe_1920)
- SOC := rtl8380
- DEVICE_MODEL := 1920-8G (JG920A)
- H3C_DEVICE_ID := 0x00010023
-endef
-TARGET_DEVICES += hpe_1920-8g
-
-define Device/hpe_1920-16g
- $(Device/hpe_1920)
- SOC := rtl8382
- DEVICE_MODEL := 1920-16G (JG923A)
- H3C_DEVICE_ID := 0x00010026
-endef
-TARGET_DEVICES += hpe_1920-16g
-
-define Device/hpe_1920-24g
- $(Device/hpe_1920)
- SOC := rtl8382
- DEVICE_MODEL := 1920-24G (JG924A)
- H3C_DEVICE_ID := 0x00010027
-endef
-TARGET_DEVICES += hpe_1920-24g
-
define Device/inaba_aml2-17gp
SOC := rtl8382
IMAGE_SIZE := 13504k