aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image
diff options
context:
space:
mode:
authorMarkus Stockhausen <markus.stockhausen@gmx.de>2022-06-16 11:41:02 +0200
committerSander Vanheule <sander@svanheule.net>2022-06-19 08:36:21 +0200
commit6153c530cc2ae139c6cdde68a4ba53bd2f82bf68 (patch)
treef719043021b62e6d6fe1e74b17789e99119f7e22 /target/linux/realtek/image
parentacbe1d4d360d859d40cfaad499b9f7c6d2f096e2 (diff)
downloadupstream-6153c530cc2ae139c6cdde68a4ba53bd2f82bf68.tar.gz
upstream-6153c530cc2ae139c6cdde68a4ba53bd2f82bf68.tar.bz2
upstream-6153c530cc2ae139c6cdde68a4ba53bd2f82bf68.zip
realtek: add support for D-Link DGS-1210-20
Hardware specification ---------------------- * RTL8382M SoC, 1 MIPS 4KEc core @ 500MHz * 128MB DRAM * 32MB NOR Flash * 16 x 10/100/1000BASE-T ports - Internal PHY with 8 ports (RTL8218B) - External PHY with 8 ports (RTL8218B) * 4 x Gigabit RJ45/SFP Combo ports - External PHY with 4 SFP ports (RTL8214FC) * Power LED * Reset button on front panel * UART (115200 8N1) via unpopulated standard 0.1" pin header marked J6 UART pinout ----------- [o]ooo|J6 | ||`------ GND | |`------- RX | `-------- TX `---------- Vcc (3V3) Boot initramfs image from U-Boot -------------------------------- 1. Press Escape key during `Hit Esc key to stop autoboot` prompt 2. Press CTRL+C keys to get into real U-Boot prompt 3. Init network with `rtk network on` command 4. Load image with `tftpboot 0x8f000000 openwrt-realtek-rtl838x-d-link_dgs-1210-20-initramfs-kernel.bin` command 5. Boot the image with `bootm` command To install, upload the sysupgrade image to the OEM webpage or sysupgrade from the system running from initramfs image. It has been developed and tested on device with F1 revision. Signed-off-by: Markus Stockhausen <markus.stockhausen@gmx.de> [correct initramfs image name] Signed-off-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'target/linux/realtek/image')
-rw-r--r--target/linux/realtek/image/rtl838x.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/realtek/image/rtl838x.mk b/target/linux/realtek/image/rtl838x.mk
index 289e37db16..df145cfb69 100644
--- a/target/linux/realtek/image/rtl838x.mk
+++ b/target/linux/realtek/image/rtl838x.mk
@@ -30,6 +30,12 @@ define Device/d-link_dgs-1210-16
endef
TARGET_DEVICES += d-link_dgs-1210-16
+define Device/d-link_dgs-1210-20
+ $(Device/d-link_dgs-1210)
+ DEVICE_MODEL := DGS-1210-20
+endef
+TARGET_DEVICES += d-link_dgs-1210-20
+
define Device/d-link_dgs-1210-28
$(Device/d-link_dgs-1210)
DEVICE_MODEL := DGS-1210-28