aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image
diff options
context:
space:
mode:
authorBirger Koblitz <git@birger-koblitz.de>2021-12-31 12:51:45 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-02-17 15:21:47 +0000
commit47f5a0a3eed593e147ee1bdd36ea532ee266ba18 (patch)
treeaabc16e06a03863b5a7cf9153132ddc1215eed1a /target/linux/realtek/image
parent0a7565e53653f3e5a3448ef892b414187b8abba2 (diff)
downloadupstream-47f5a0a3eed593e147ee1bdd36ea532ee266ba18.tar.gz
upstream-47f5a0a3eed593e147ee1bdd36ea532ee266ba18.tar.bz2
upstream-47f5a0a3eed593e147ee1bdd36ea532ee266ba18.zip
realtek: Add support for ZyXEL GS1900-48 Switch
The GS1900-48 is a 48 + 2 port Gigabit L2 switch with 48 gigabit ports. Hardware: RTL8393M SoC Macronix MX25l12805D (16MB flash) 128MB RAM 6 * RTL8218B external PHY 2 * RTL8231 GPIO extenders to control the port LEDs, system LED and Reset button 2 Uplink ports are SFP cages which support 1000 Base-X mini GBIC modules. Power is supplied via a 230 volt mains connector. The board has a hard reset switch SW1, which is is not reachable from the outside. J4 provides a 12V RS232 serial connector which is connected through U8 to the 3.3V UART of the RTL8393. Conversion is done by U8, a SIPEX 3232EC. To connect to the UART, wires can be soldered to R603 (TX) and R602 (RX). Installation: Install the squashfs image via Realtek's original Web-Interface. Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
Diffstat (limited to 'target/linux/realtek/image')
-rw-r--r--target/linux/realtek/image/rtl839x.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/realtek/image/rtl839x.mk b/target/linux/realtek/image/rtl839x.mk
new file mode 100644
index 0000000000..2363b91849
--- /dev/null
+++ b/target/linux/realtek/image/rtl839x.mk
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+define Device/zyxel_gs1900-48
+ SOC := rtl8393
+ IMAGE_SIZE := 13952k
+ DEVICE_VENDOR := ZyXEL
+ UIMAGE_MAGIC := 0x83800000
+ ZYXEL_VERS := AAHO
+ DEVICE_MODEL := GS1900-48
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | zyxel-vers $$$$(ZYXEL_VERS) | \
+ uImage gzip
+endef
+TARGET_DEVICES += zyxel_gs1900-48