aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2021-08-11 20:23:06 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-09-26 00:32:17 +0200
commit0de230bd0ce1c011a6d57ce7692b1b7898e7b735 (patch)
tree0fe90006f3b132044f9f63aa7ef2fc60a777e35c /target/linux/realtek/image
parent9e418b061c1720d677e73f2ee06651533889a69a (diff)
downloadupstream-0de230bd0ce1c011a6d57ce7692b1b7898e7b735.tar.gz
upstream-0de230bd0ce1c011a6d57ce7692b1b7898e7b735.tar.bz2
upstream-0de230bd0ce1c011a6d57ce7692b1b7898e7b735.zip
realtek: copy dts directory for Kernel 5.10
This patch adds "dts-5.10" directory to use backported drivers. There are several specification changes in the new drivers, so there are some compatibility issues in using dts/dtsi files for 5.4. The old DTS files are moved to "dts-5.4", so their corresponding kernel version is obvious as well. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> [change "dts" to "dts-5.4", adjust Makefile] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/realtek/image')
-rw-r--r--target/linux/realtek/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 5900750797..5e4b4cde80 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -20,7 +20,7 @@ define Device/Default
PROFILES = Default
KERNEL := kernel-bin | append-dtb | gzip | uImage gzip
KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | uImage gzip
- DEVICE_DTS_DIR := ../dts
+ DEVICE_DTS_DIR := ../dts-$(KERNEL_PATCHVER)
DEVICE_DTS = $$(SOC)_$(1)
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | \