aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image/rtl839x.mk
diff options
context:
space:
mode:
authorSander Vanheule <sander@svanheule.net>2022-09-17 22:06:37 +0200
committerSander Vanheule <sander@svanheule.net>2022-09-17 22:12:35 +0200
commit9338c09ecbfa40522eec061728302fd8ae49dce3 (patch)
tree9984915d456a55b0c8d5c583e54de0f7e851c4bd /target/linux/realtek/image/rtl839x.mk
parente04e821471bb12d5602ab48bcdd1ce1add99daf9 (diff)
downloadupstream-9338c09ecbfa40522eec061728302fd8ae49dce3.tar.gz
upstream-9338c09ecbfa40522eec061728302fd8ae49dce3.tar.bz2
upstream-9338c09ecbfa40522eec061728302fd8ae49dce3.zip
realtek: merge duplicated DGS-1210 recipes
The D-Link DGS-1210 device series currently has supported devices with both RTL838x and RTL839x SoCs. An image build recipe has been defined in both subtarget makefiles, but these are mostly identical, save for the SOC variable. Move the SOC variable from the DGS-1210 build recipes to the applicable devices, and put the remaining duplicate code in a shared Makefile. Signed-off-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'target/linux/realtek/image/rtl839x.mk')
-rw-r--r--target/linux/realtek/image/rtl839x.mk19
1 files changed, 3 insertions, 16 deletions
diff --git a/target/linux/realtek/image/rtl839x.mk b/target/linux/realtek/image/rtl839x.mk
index 1820875ffd..f4704544a6 100644
--- a/target/linux/realtek/image/rtl839x.mk
+++ b/target/linux/realtek/image/rtl839x.mk
@@ -1,23 +1,10 @@
# SPDX-License-Identifier: GPL-2.0-only
-define Device/d-link_dgs-1210
- SOC := rtl8393
- IMAGE_SIZE := 13824k
- DEVICE_VENDOR := D-Link
- DLINK_KERNEL_PART_SIZE := 1572864
- KERNEL := kernel-bin | append-dtb | gzip | uImage gzip | dlink-cameo
- CAMEO_KERNEL_PART := 2
- CAMEO_ROOTFS_PART := 3
- CAMEO_CUSTOMER_SIGNATURE := 2
- CAMEO_BOARD_VERSION := 32
- IMAGES += factory_image1.bin
- IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
- append-rootfs | pad-rootfs | pad-to 16 | check-size | \
- dlink-version | dlink-headers
-endef
+include ./common.mk
define Device/d-link_dgs-1210-52
- $(Device/d-link_dgs-1210)
+ $(Build/d-link_dgs-1210)
+ SOC := rtl8393
DEVICE_MODEL := DGS-1210-52
endef
TARGET_DEVICES += d-link_dgs-1210-52