aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image/rtl838x.mk
diff options
context:
space:
mode:
authorSander Vanheule <sander@svanheule.net>2022-09-17 22:06:37 +0200
committerSander Vanheule <sander@svanheule.net>2022-09-17 22:12:35 +0200
commit9338c09ecbfa40522eec061728302fd8ae49dce3 (patch)
tree9984915d456a55b0c8d5c583e54de0f7e851c4bd /target/linux/realtek/image/rtl838x.mk
parente04e821471bb12d5602ab48bcdd1ce1add99daf9 (diff)
downloadupstream-9338c09ecbfa40522eec061728302fd8ae49dce3.tar.gz
upstream-9338c09ecbfa40522eec061728302fd8ae49dce3.tar.bz2
upstream-9338c09ecbfa40522eec061728302fd8ae49dce3.zip
realtek: merge duplicated DGS-1210 recipes
The D-Link DGS-1210 device series currently has supported devices with both RTL838x and RTL839x SoCs. An image build recipe has been defined in both subtarget makefiles, but these are mostly identical, save for the SOC variable. Move the SOC variable from the DGS-1210 build recipes to the applicable devices, and put the remaining duplicate code in a shared Makefile. Signed-off-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'target/linux/realtek/image/rtl838x.mk')
-rw-r--r--target/linux/realtek/image/rtl838x.mk31
1 files changed, 10 insertions, 21 deletions
diff --git a/target/linux/realtek/image/rtl838x.mk b/target/linux/realtek/image/rtl838x.mk
index 36b19b3cbb..2fe2013f70 100644
--- a/target/linux/realtek/image/rtl838x.mk
+++ b/target/linux/realtek/image/rtl838x.mk
@@ -1,5 +1,6 @@
# SPDX-License-Identifier: GPL-2.0-only
+include ./common.mk
define Device/allnet_all-sg8208m
SOC := rtl8382
@@ -11,24 +12,8 @@ define Device/allnet_all-sg8208m
endef
TARGET_DEVICES += allnet_all-sg8208m
-define Device/d-link_dgs-1210
- SOC := rtl8382
- IMAGE_SIZE := 13824k
- DEVICE_VENDOR := D-Link
- DLINK_KERNEL_PART_SIZE := 1572864
- KERNEL := kernel-bin | append-dtb | gzip | uImage gzip | dlink-cameo
- CAMEO_KERNEL_PART := 2
- CAMEO_ROOTFS_PART := 3
- CAMEO_CUSTOMER_SIGNATURE := 2
- CAMEO_BOARD_VERSION := 32
- IMAGES += factory_image1.bin
- IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
- append-rootfs | pad-rootfs | pad-to 16 | check-size | \
- dlink-version | dlink-headers
-endef
-
define Device/d-link_dgs-1210-10mp-f
- $(Device/d-link_dgs-1210)
+ $(Build/d-link_dgs-1210)
SOC := rtl8380
DEVICE_MODEL := DGS-1210-10MP
DEVICE_VARIANT := F
@@ -37,26 +22,30 @@ endef
TARGET_DEVICES += d-link_dgs-1210-10mp-f
define Device/d-link_dgs-1210-10p
- $(Device/d-link_dgs-1210)
+ $(Build/d-link_dgs-1210)
+ SOC := rtl8382
DEVICE_MODEL := DGS-1210-10P
DEVICE_PACKAGES += lua-rs232
endef
TARGET_DEVICES += d-link_dgs-1210-10p
define Device/d-link_dgs-1210-16
- $(Device/d-link_dgs-1210)
+ $(Build/d-link_dgs-1210)
+ SOC := rtl8382
DEVICE_MODEL := DGS-1210-16
endef
TARGET_DEVICES += d-link_dgs-1210-16
define Device/d-link_dgs-1210-20
- $(Device/d-link_dgs-1210)
+ $(Build/d-link_dgs-1210)
+ SOC := rtl8382
DEVICE_MODEL := DGS-1210-20
endef
TARGET_DEVICES += d-link_dgs-1210-20
define Device/d-link_dgs-1210-28
- $(Device/d-link_dgs-1210)
+ $(Build/d-link_dgs-1210)
+ SOC := rtl8382
DEVICE_MODEL := DGS-1210-28
endef
TARGET_DEVICES += d-link_dgs-1210-28