aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image/Makefile
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2022-12-14 15:16:33 +0100
committerSander Vanheule <sander@svanheule.net>2023-01-02 10:18:44 +0100
commit9260027535b8f7eab5481b7f545a3fc6477d14fa (patch)
tree13adfd7d332fcd57097f07f91761fcc2acdd09d2 /target/linux/realtek/image/Makefile
parenta51ca085bff2f8c6155f18bb767fe2d053bbc90d (diff)
downloadupstream-9260027535b8f7eab5481b7f545a3fc6477d14fa.tar.gz
upstream-9260027535b8f7eab5481b7f545a3fc6477d14fa.tar.bz2
upstream-9260027535b8f7eab5481b7f545a3fc6477d14fa.zip
realtek: Migrate to libdeflate
Libdeflate is a more advanced gzip compressor, which allows for faster decompression, higher compression speed (factor 3-4), while being fully gzip compatible. Some comparison gzip | libdeflate-gzip | delta | image [openwrt-realtek-rtl839x-*] --------+-----------------+--------+----------------------------------------------- 6589174 | 6298794 | 290380 | d-link_dgs-1210-52-initramfs-kernel.bin 6291632 | 6029488 | 262144 | d-link_dgs-1210-52-squashfs-factory_image1.bin 6292270 | 6030128 | 262142 | d-link_dgs-1210-52-squashfs-sysupgrade.bin 6589142 | 6298760 | 290382 | zyxel_gs1900-48-initramfs-kernel.bin 6292264 | 6030122 | 262142 | zyxel_gs1900-48-squashfs-sysupgrade.bin and changing lzma to (libdeflate-)gzip on existing rtl930x target: gzip | libdeflate-gzip | delta | image [openwrt-realtek-rtl930x-*] --------+-----------------+--------+-------------------------------------- 6816230 | 6510382 | 305848 | zyxel_xgs1250-12-initramfs-kernel.bin Signed-off-by: Olliver Schinagl <oliver@schinagl.nl> Reviewed-by: Robert Marko <robimarko@gmail.com> Reviewed-by: Rosen Penev <rosenp@gmail.com> Reviewed-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'target/linux/realtek/image/Makefile')
-rw-r--r--target/linux/realtek/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 66d7ee4895..7c5b67191c 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -90,12 +90,12 @@ define Device/Default
KERNEL := \
kernel-bin | \
append-dtb | \
- gzip | \
+ libdeflate-gzip | \
uImage gzip
KERNEL_INITRAMFS := \
kernel-bin | \
append-dtb | \
- gzip | \
+ libdeflate-gzip | \
uImage gzip
DEVICE_DTS_DIR := ../dts-$(KERNEL_PATCHVER)
DEVICE_DTS = $$(SOC)_$(1)