aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-02-28 21:57:55 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-29 14:28:19 +0200
commit27fbae4c5af612b1a1790c35a30b154b8e888057 (patch)
treede5c9aeb81b1ff8320c3b8ab0764d86171033d51 /target/linux/realtek/Makefile
parent916f21c63e974b2543b19345c8ff7102106e858c (diff)
downloadupstream-27fbae4c5af612b1a1790c35a30b154b8e888057.tar.gz
upstream-27fbae4c5af612b1a1790c35a30b154b8e888057.tar.bz2
upstream-27fbae4c5af612b1a1790c35a30b154b8e888057.zip
realtek: Use firewall4
The realtek target is not a router, but basic device, see DEVICE_TYPE. The basic device type does not come with firewall by default, see include/target.mk for details. The realtek target extended DEFAULT_PACKAGES manually with firewall. This changes the defaults to take firewall4 and nftables instead of firewall and iptables. This also adds the additional package kmod-nft-offload. The only difference to the router type is the missing ppp, ppp-mod-pppoe, dnsmasq and odhcpd-ipv6only package. This increases the compressed image size by about 422KBytes. Tested-by: Stijn Segers <foss@volatilesystems.org> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit 469030659c5cb140bdbff1b3d8fc9691f98f984b)
Diffstat (limited to 'target/linux/realtek/Makefile')
-rw-r--r--target/linux/realtek/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/realtek/Makefile b/target/linux/realtek/Makefile
index 1fd9a870cd..8bed3d8a72 100644
--- a/target/linux/realtek/Makefile
+++ b/target/linux/realtek/Makefile
@@ -18,7 +18,7 @@ endef
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
- firewall ip6tables iptables odhcp6c \
+ firewall4 nftables kmod-nft-offload odhcp6c \
ip-full ip-bridge tc
$(eval $(call BuildTarget))