aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-10 23:08:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-10 23:08:11 +0000
commit1bca0cc51704b5ef57c5e3a9d7a1b80633486d16 (patch)
tree44d959af03ba5f4cf55929b6d930439b6335d0c4 /target/linux/rdc
parentf8d965201b053be42f7690a75fd0a529608c5af3 (diff)
downloadupstream-1bca0cc51704b5ef57c5e3a9d7a1b80633486d16.tar.gz
upstream-1bca0cc51704b5ef57c5e3a9d7a1b80633486d16.tar.bz2
upstream-1bca0cc51704b5ef57c5e3a9d7a1b80633486d16.zip
make the image filenames a bit shorter
SVN-Revision: 9533
Diffstat (limited to 'target/linux/rdc')
-rw-r--r--target/linux/rdc/image/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/rdc/image/Makefile b/target/linux/rdc/image/Makefile
index 3382a1d287..4d8c5fda33 100644
--- a/target/linux/rdc/image/Makefile
+++ b/target/linux/rdc/image/Makefile
@@ -22,11 +22,11 @@ bs=1024
endef
define Image/Build/ar525w
- touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-$(2).img
+ touch $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
mv $(KDIR)/root.$(1) $(KDIR)/root.tmp
dd of=$(KDIR)/root.$(1) if=$(KDIR)/root.tmp $(call trxalign/$(1)) conv=sync
$(RM) $(KDIR)/root.tmp
- $(STAGING_DIR_HOST)/bin/airlink -b 1 -j $(shell bash -c 'echo $$[$(3)]') $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-$(2).img
+ $(STAGING_DIR_HOST)/bin/airlink -b 1 -j $(shell bash -c 'echo $$[$(3)]') $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
endef
define Image/Build/wl153
@@ -34,15 +34,15 @@ define Image/Build/wl153
gzip -9c $(KDIR)/root.$(1) > $(KDIR)/root.$(1).gz
ls -l $(KDIR)/root.$(1).gz | sed -r 's/^[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+[^[:blank:]]+[[:blank:]]+([^[:blank:]]+).+$$$$/\1/' | xargs printf '%.8x' > $(KDIR)/rdSize
echo -ne "\x$$$$(cut -c 7,8 < $(KDIR)/bzSize)\x$$$$(cut -c 5,6 < $(KDIR)/bzSize)\x$$$$(cut -c 3,4 < $(KDIR)/bzSize)\x$$$$(cut -c 1,2 < $(KDIR)/bzSize)" > $(KDIR)/bzSize.tmp
- echo -n 'CSYS' > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-$(2).img
- cat $(KDIR)/bzSize.tmp >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-$(2).img
- echo -ne "\x$$$$(cut -c 7,8 < $(KDIR)/rdSize)\x$$$$(cut -c 5,6 < $(KDIR)/rdSize)\x$$$$(cut -c 3,4 < $(KDIR)/rdSize)\x$$$$(cut -c 1,2 < $(KDIR)/rdSize)WRRM" >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-$(2).img
- cat $(KDIR)/bzSize.tmp $(KDIR)/bzImage $(KDIR)/root.$(1).gz >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-$(2).img
+ echo -n 'CSYS' > $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+ cat $(KDIR)/bzSize.tmp >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+ echo -ne "\x$$$$(cut -c 7,8 < $(KDIR)/rdSize)\x$$$$(cut -c 5,6 < $(KDIR)/rdSize)\x$$$$(cut -c 3,4 < $(KDIR)/rdSize)\x$$$$(cut -c 1,2 < $(KDIR)/rdSize)WRRM" >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+ cat $(KDIR)/bzSize.tmp $(KDIR)/bzImage $(KDIR)/root.$(1).gz >> $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
$(RM) $(KDIR)/bzSize.tmp $(KDIR)/bzSize $(KDIR)/rdSize
endef
define Image/Build/dir450
- touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-$(2).img
+ touch $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
mv $(KDIR)/root.$(1) $(KDIR)/root.tmp
dd of=$(KDIR)/root.$(1) if=$(KDIR)/root.tmp $(call trxalign/$(1)) conv=sync
$(RM) $(KDIR)/root.tmp
@@ -50,7 +50,7 @@ define Image/Build/dir450
endef
define Image/Build
- $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).bzImage
+ $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD).bzImage
$(call Image/Build/$(PROFILE),$(1),$(PROFILE),$(patsubst jffs2-%k,%,$(1)))
endef