aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/profiles/sitecom.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-25 10:13:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-25 10:13:00 +0000
commit821bd49569acf55cc6489c762dc279f6da838dee (patch)
tree397901ecc16c129354cb037dac2ea1833855bdcb /target/linux/rdc/profiles/sitecom.mk
parent35bb7be34d30252059144c1855f7397695b9362c (diff)
downloadupstream-821bd49569acf55cc6489c762dc279f6da838dee.tar.gz
upstream-821bd49569acf55cc6489c762dc279f6da838dee.tar.bz2
upstream-821bd49569acf55cc6489c762dc279f6da838dee.zip
use profiles again intead of subtargets.
We have now a single kernel which autodetects the type of device we are running on, so we can switch back to having profiles. Patch by Bernhard Loos. SVN-Revision: 20416
Diffstat (limited to 'target/linux/rdc/profiles/sitecom.mk')
-rw-r--r--target/linux/rdc/profiles/sitecom.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/rdc/profiles/sitecom.mk b/target/linux/rdc/profiles/sitecom.mk
new file mode 100644
index 0000000000..e3b2981ed8
--- /dev/null
+++ b/target/linux/rdc/profiles/sitecom.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/sitecom
+ NAME:=Devices from Sitecom (WL-153, DC-230)
+ PACKAGES:=kmod-rt61-pci kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+$(eval $(call Profile,sitecom))