aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-25 10:13:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-25 10:13:00 +0000
commitc0407fae658a0775a051de180be27e26afbdfc7b (patch)
treed72fc52574b08aba1f5933f58654a12e965d22d9 /target/linux/rdc/image
parent8e17bf613a5facf33fd12faf400a4ac9c6c9994d (diff)
downloadupstream-c0407fae658a0775a051de180be27e26afbdfc7b.tar.gz
upstream-c0407fae658a0775a051de180be27e26afbdfc7b.tar.bz2
upstream-c0407fae658a0775a051de180be27e26afbdfc7b.zip
[rdc] use profiles again intead of subtargets.
We have now a single kernel which autodetects the type of device we are running on, so we can switch back to having profiles. Patch by Bernhard Loos. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20416 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rdc/image')
-rw-r--r--target/linux/rdc/image/Makefile16
1 files changed, 1 insertions, 15 deletions
diff --git a/target/linux/rdc/image/Makefile b/target/linux/rdc/image/Makefile
index 59d59b4a72..13e9da1fad 100644
--- a/target/linux/rdc/image/Makefile
+++ b/target/linux/rdc/image/Makefile
@@ -11,20 +11,6 @@ define Image/Prepare
$(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
endef
-define trxalign/jffs2-128k
-bs=128k
-endef
-define trxalign/jffs2-64k
-bs=64k
-endef
-define trxalign/squashfs
-bs=1024
-endef
-
-define Image/Prepare/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-endef
-
define Image/Build/ar525w
cp $(KDIR)/bzImage $(KDIR)/bzImage.tmp
$(SCRIPT_DIR)/pad_image $(1) $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) 32
@@ -53,7 +39,7 @@ endef
define Image/Build
$(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD).bzImage
- $(call Image/Build/$(SUBTARGET),$(1),$(SUBTARGET),$(patsubst jffs2-%k,%,$(1)))
+ $(call Image/Build/$(PROFILE),$(1),$(PROFILE),$(patsubst jffs2-%k,%,$(1)))
ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
$(call Image/Build/Initramfs)
endif