aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-08-05 13:42:36 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-08-05 13:42:36 +0000
commit1b0318158d9b80b773f643454dc1aed9a1926deb (patch)
tree90654f50005ec1ad778c86fb8f381400e5d558f5 /target/linux/rdc/Makefile
parent027a7939f17e50432db03c3ea354c3d40c9de614 (diff)
downloadupstream-1b0318158d9b80b773f643454dc1aed9a1926deb.tar.gz
upstream-1b0318158d9b80b773f643454dc1aed9a1926deb.tar.bz2
upstream-1b0318158d9b80b773f643454dc1aed9a1926deb.zip
Reinstate rdc bootability and force it to use init=/etc/preinit, thus the remove the hackish SetInitramfs actions
SVN-Revision: 12136
Diffstat (limited to 'target/linux/rdc/Makefile')
-rw-r--r--target/linux/rdc/Makefile12
1 files changed, 0 insertions, 12 deletions
diff --git a/target/linux/rdc/Makefile b/target/linux/rdc/Makefile
index 89fab7149b..d56bac0107 100644
--- a/target/linux/rdc/Makefile
+++ b/target/linux/rdc/Makefile
@@ -20,16 +20,4 @@ define Target/Description
(e.g. Airlink101 AR525W, Linksys WRT54R, Sitecom WL-153)
endef
-ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
- define Kernel/SetInitramfs
- echo "r6040 parent=wlan0" > $(TARGET_DIR)/etc/modules.d/99-r6040
- $(RM) $(TARGET_DIR)/sbin/init
- ln -s /etc/preinit $(TARGET_DIR)/sbin/init
- sed -i 's,exec /sbin/init,exec /bin/busybox init,g' $(TARGET_DIR)/etc/preinit
- sed -i 's,/sbin/init,/bin/busybox init,g' $(TARGET_DIR)/init
- mv $(TARGET_DIR)/init $(TARGET_DIR)/linuxrc
- sed -i 's,eth0,eth1,g' $(TARGET_DIR)/etc/config/network
- endef
-endif
-
$(eval $(call BuildTarget))