aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
commit53aef8417d5b9e00e4b74b022ed03975c732d8e9 (patch)
tree56570ca509d7826cb8163622a96ddac70562068c /target/linux/rdc-2.6
parentbf32023e6c902f04f995d7e787a72129794a16ba (diff)
downloadupstream-53aef8417d5b9e00e4b74b022ed03975c732d8e9.tar.gz
upstream-53aef8417d5b9e00e4b74b022ed03975c732d8e9.tar.bz2
upstream-53aef8417d5b9e00e4b74b022ed03975c732d8e9.zip
Add initial version of the new Image Builder
It's still a bit rough in a few places, but it seems to work for Broadcom at least - other targets untested. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6071 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rdc-2.6')
-rw-r--r--target/linux/rdc-2.6/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/rdc-2.6/image/Makefile b/target/linux/rdc-2.6/image/Makefile
index 13c8718430..078e754e10 100644
--- a/target/linux/rdc-2.6/image/Makefile
+++ b/target/linux/rdc-2.6/image/Makefile
@@ -11,11 +11,12 @@ define Build/Clean
endef
define Image/Prepare
+ $(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
endef
define Image/Build
touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
- $(STAGING_DIR)/bin/airlink -b 0 -j $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+ $(STAGING_DIR)/bin/airlink -b 0 -j $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
endef
$(eval $(call BuildImage))