aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-10-15 23:34:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-10-15 23:34:22 +0000
commit44419aed87f1c2ea1024535edabc1c3a250b6fc8 (patch)
tree777ec7969e32815eb729a942b76a86ba88a36db2 /target/linux/rdc-2.6/Makefile
parent875927a153f1ea538280afc0ce04e75c91683f5e (diff)
downloadupstream-44419aed87f1c2ea1024535edabc1c3a250b6fc8.tar.gz
upstream-44419aed87f1c2ea1024535edabc1c3a250b6fc8.tar.bz2
upstream-44419aed87f1c2ea1024535edabc1c3a250b6fc8.zip
Merge preliminary rdc-2.6 support (Airlink101 AR525W)
SVN-Revision: 5138
Diffstat (limited to 'target/linux/rdc-2.6/Makefile')
-rw-r--r--target/linux/rdc-2.6/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/rdc-2.6/Makefile b/target/linux/rdc-2.6/Makefile
new file mode 100644
index 0000000000..59f02b3340
--- /dev/null
+++ b/target/linux/rdc-2.6/Makefile
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+LINUX_VERSION:=2.6.17
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+
+include ./config
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/kernel-build.mk
+
+$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
+ [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
+ [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
+ @$(CP) config $(LINUX_DIR)/.config
+ touch $@