aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit56231056ea784f1cec6450f649b1adaed1f56366 (patch)
tree7b130d72d854cde2bcd3af8b11bd0f7be3dbff6a /target/linux/rdc-2.6/Makefile
parente1184aaa1a7a5e5eeef8e072bf0ea98c291be22a (diff)
downloadupstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.gz
upstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.bz2
upstream-56231056ea784f1cec6450f649b1adaed1f56366.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
SVN-Revision: 8653
Diffstat (limited to 'target/linux/rdc-2.6/Makefile')
-rw-r--r--target/linux/rdc-2.6/Makefile38
1 files changed, 0 insertions, 38 deletions
diff --git a/target/linux/rdc-2.6/Makefile b/target/linux/rdc-2.6/Makefile
deleted file mode 100644
index 5af5e85c6e..0000000000
--- a/target/linux/rdc-2.6/Makefile
+++ /dev/null
@@ -1,38 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-ARCH:=i386
-BOARD:=rdc
-BOARDNAME:=RDC321x x86
-FEATURES:=squashfs jffs2 broken
-
-LINUX_VERSION:=2.6.22.4
-
-define Target/Description
- Build firmware images for RDC321x based routers
- (e.g. Airlink101 AR525W, Linksys WRT54R, Sitecom WL-153)
-endef
-
-include $(INCLUDE_DIR)/kernel-build.mk
-
-ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
- define Kernel/SetInitramfs
- echo "r6040 parent=wlan0" > $(TARGET_DIR)/etc/modules.d/99-r6040
- $(RM) $(TARGET_DIR)/sbin/init
- ln -s /etc/preinit $(TARGET_DIR)/sbin/init
- sed -i 's,exec /sbin/init,exec /bin/busybox init,g' $(TARGET_DIR)/etc/preinit
- sed -i 's,/sbin/init,/bin/busybox init,g' $(TARGET_DIR)/init
- mv $(TARGET_DIR)/init $(TARGET_DIR)/linuxrc
- sed -i 's,eth0,eth1,g' $(TARGET_DIR)/etc/config/network
- endef
-endif
-
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))