aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-07-15 17:17:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-07-15 17:17:04 +0000
commitbb34f3521e9c8328772ab19afcb1a1b666631fd6 (patch)
tree03c3dac161ce721fd65cb2f2d967eda861999b74 /target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch
parent8deed3752fab08ca2fcb324c11834aa3f199510f (diff)
downloadupstream-bb34f3521e9c8328772ab19afcb1a1b666631fd6.tar.gz
upstream-bb34f3521e9c8328772ab19afcb1a1b666631fd6.tar.bz2
upstream-bb34f3521e9c8328772ab19afcb1a1b666631fd6.zip
Move files and patches to files-2.6.23 and patches-2.6.23
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11843 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch')
-rw-r--r--target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch b/target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch
new file mode 100644
index 0000000000..acfba6c00a
--- /dev/null
+++ b/target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch
@@ -0,0 +1,31 @@
+Index: linux-2.6.23.17/drivers/net/Kconfig
+===================================================================
+--- linux-2.6.23.17.orig/drivers/net/Kconfig
++++ linux-2.6.23.17/drivers/net/Kconfig
+@@ -348,6 +348,13 @@ config AX88796
+ AX88796 driver, using platform bus to provide
+ chip detection and resources
+
++config KORINA
++ tristate "Korina Local Ethernet support"
++ depends on NET_ETHERNET && ( IDT_EB434 || MIKROTIK_RB500)
++ help
++ IDT RC32434 has one local ethernet port. Say Y here to enable it.
++ To compile this driver as a module, choose M here.
++
+ config MACE
+ tristate "MACE (Power Mac ethernet) support"
+ depends on PPC_PMAC && PPC32
+Index: linux-2.6.23.17/drivers/net/Makefile
+===================================================================
+--- linux-2.6.23.17.orig/drivers/net/Makefile
++++ linux-2.6.23.17/drivers/net/Makefile
+@@ -25,6 +25,8 @@ ucc_geth_driver-objs := ucc_geth.o ucc_g
+ #
+ obj-$(CONFIG_PLIP) += plip.o
+
++obj-$(CONFIG_KORINA) += korina.o
++
+ obj-$(CONFIG_ROADRUNNER) += rrunner.o
+
+ obj-$(CONFIG_HAPPYMEAL) += sunhme.o