aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532-2.6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-03 22:36:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-03 22:36:45 +0000
commit89a182243867096931874d8c5d4ee1c7c1585a44 (patch)
tree9d7a2884682fb985b44b0cb9491ff2fbdbc9647c /target/linux/rb532-2.6
parent95d20db041eb1ae1c813abe6daa92210b8fb95ed (diff)
downloadupstream-89a182243867096931874d8c5d4ee1c7c1585a44.tar.gz
upstream-89a182243867096931874d8c5d4ee1c7c1585a44.tar.bz2
upstream-89a182243867096931874d8c5d4ee1c7c1585a44.zip
enable preinit in a few other platforms
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6482 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532-2.6')
-rwxr-xr-xtarget/linux/rb532-2.6/base-files/default/sbin/cf2nand2
-rw-r--r--target/linux/rb532-2.6/image/Makefile6
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/rb532-2.6/base-files/default/sbin/cf2nand b/target/linux/rb532-2.6/base-files/default/sbin/cf2nand
index 9cb216ca82..74ac89402b 100755
--- a/target/linux/rb532-2.6/base-files/default/sbin/cf2nand
+++ b/target/linux/rb532-2.6/base-files/default/sbin/cf2nand
@@ -45,7 +45,7 @@ mount -t yaffs2 "$boot" /tmp/cf2nand/p1
mount -t yaffs2 "$main" /tmp/cf2nand/p2
echo "Copying kernel..."
-copy_kernel /dev/cf/card0/part1 /tmp/cf2nand/p1/kernel "root=/dev/mtdblock1 rootfstype=yaffs2 " 2>/dev/null >/dev/null
+copy_kernel /dev/cf/card0/part1 /tmp/cf2nand/p1/kernel "root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit " 2>/dev/null >/dev/null
umount /tmp/cf2nand/p1
rmdir /tmp/cf2nand/p1
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index e6794c036d..149a7e2734 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -38,15 +38,15 @@ define Image/BuildKernel
endef
define Image/cmdline/jffs2-64k
-block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=jffs2
+block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
endef
define Image/cmdline/jffs2-128k
-block2mtd.block2mtd=/dev/cfa2,131072 root=/dev/mtdblock0 rootfstype=jffs2
+block2mtd.block2mtd=/dev/cfa2,131072 root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
endef
define Image/cmdline/ext2
-root=/dev/cfa2 rootfstype=ext2
+root=/dev/cfa2 rootfstype=ext2 init=/etc/preinit
endef
define Image/Build