aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532-2.6/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-11 22:58:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-11 22:58:44 +0000
commita53acfc435be4344aff595b6c2faa93a2f2dc571 (patch)
tree5698134111a94767e4ed6428cdca2aa55b470bc8 /target/linux/rb532-2.6/image
parentb0e37ff9eb71a6b7e89ccdde7cdce59acb5c4656 (diff)
downloadupstream-a53acfc435be4344aff595b6c2faa93a2f2dc571.tar.gz
upstream-a53acfc435be4344aff595b6c2faa93a2f2dc571.tar.bz2
upstream-a53acfc435be4344aff595b6c2faa93a2f2dc571.zip
fix rb532 squashfs support (patch by Jens Muecke)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7577 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rb532-2.6/image')
-rw-r--r--target/linux/rb532-2.6/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 149a7e2734..f53c5e4ac3 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -49,6 +49,10 @@ define Image/cmdline/ext2
root=/dev/cfa2 rootfstype=ext2 init=/etc/preinit
endef
+define Image/cmdline/squashfs
+root=/dev/cfa2 rootfstype=squashfs init=/etc/preinit
+endef
+
define Image/Build
$(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)