aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-06 18:31:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-06 18:31:28 +0000
commit63994b8f50ca94e0885ed9a00c29eaeeda7c36fe (patch)
treebf0a2663a31ed16a9ae7550e05818f77f6d20177 /target/linux/rb532-2.6/image/Makefile
parente1dc2f086daaa231d50a3852afad8642353add0f (diff)
downloadupstream-63994b8f50ca94e0885ed9a00c29eaeeda7c36fe.tar.gz
upstream-63994b8f50ca94e0885ed9a00c29eaeeda7c36fe.tar.bz2
upstream-63994b8f50ca94e0885ed9a00c29eaeeda7c36fe.zip
replace the ugly rb532 cmdline hack with a cleaner one that does not depend on magic offsets
SVN-Revision: 5699
Diffstat (limited to 'target/linux/rb532-2.6/image/Makefile')
-rw-r--r--target/linux/rb532-2.6/image/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 27e4357a83..4907214469 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -20,17 +20,16 @@ LOADER_MAKEOPTS= \
RAMSIZE=$(RAMSIZE) \
IMAGE_COPY=$(IMAGE_COPY)
+define Build/Compile
+ $(CC) -o $(STAGING_DIR)/bin/patch-cmdline $(PLATFORM_DIR)/src/patch-cmdline.c
+endef
+
define Build/Clean
$(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef
-CMDLINE_SIZE=512
-CMDLINE_OFFSET=4112
-
define Image/Prepare
- echo 'root=/dev/cfa2 ' | \
- dd bs=$(CMDLINE_SIZE) count=1 conv=sync | \
- dd of=$(LINUX_DIR)/vmlinux bs=$(CMDLINE_OFFSET) conv=notrunc seek=1
+ $(STAGING_DIR)/bin/patch-cmdline $(LINUX_DIR)/vmlinux 'root=/dev/cfa2 '
$(KERNEL_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)
endef
@@ -56,9 +55,7 @@ root=/dev/cfa2 rootfstype=ext2
endef
define Image/Build
- echo '$(strip $(call Image/cmdline/$(1))) ' | \
- dd bs=$(CMDLINE_SIZE) count=1 conv=sync | \
- dd of=$(LINUX_DIR)/vmlinux bs=$(CMDLINE_OFFSET) conv=notrunc seek=1
+ $(STAGING_DIR)/bin/patch-cmdline $(LINUX_DIR)/vmlinux '$(strip $(call Image/cmdline/$(1))) '
( \
echo -ne OWRT | dd bs=$$$$((0x1be)) conv=sync; \
( \