aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb1xx-2.6/patches/500-Nand.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-02 16:59:59 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-02 16:59:59 +0000
commit3e8d73d762c0e473bcfa49dbdc488b48ba57e06a (patch)
tree49b3d3f10ddedb39df71c2cdac6b597d2115a6cc /target/linux/rb1xx-2.6/patches/500-Nand.patch
parent75262124ba989c05a5840d8ad878429589e68249 (diff)
downloadupstream-3e8d73d762c0e473bcfa49dbdc488b48ba57e06a.tar.gz
upstream-3e8d73d762c0e473bcfa49dbdc488b48ba57e06a.tar.bz2
upstream-3e8d73d762c0e473bcfa49dbdc488b48ba57e06a.zip
Add preliminary RouterBoard RB1xx support
SVN-Revision: 6839
Diffstat (limited to 'target/linux/rb1xx-2.6/patches/500-Nand.patch')
-rw-r--r--target/linux/rb1xx-2.6/patches/500-Nand.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/rb1xx-2.6/patches/500-Nand.patch b/target/linux/rb1xx-2.6/patches/500-Nand.patch
new file mode 100644
index 0000000000..05cc800aac
--- /dev/null
+++ b/target/linux/rb1xx-2.6/patches/500-Nand.patch
@@ -0,0 +1,27 @@
+diff -urN linux.old/drivers/mtd/nand/Kconfig linux.dev/drivers/mtd/nand/Kconfig
+--- linux.old/drivers/mtd/nand/Kconfig 2006-11-29 22:57:37.000000000 +0100
++++ linux.dev/drivers/mtd/nand/Kconfig 2006-12-14 04:38:51.000000000 +0100
+@@ -75,6 +75,12 @@
+ help
+ Support for NAND flash on Technologic Systems TS-7250 platform.
+
++config MTD_NAND_RB500
++ tristate "NAND Flash device on RB500 board"
++ depends on MTD_NAND
++ help
++ Support for NAND flash on RB500 platform.
++
+ config MTD_NAND_IDS
+ tristate
+
+diff -urN linux.old/drivers/mtd/nand/Makefile linux.dev/drivers/mtd/nand/Makefile
+--- linux.old/drivers/mtd/nand/Makefile 2006-11-29 22:57:37.000000000 +0100
++++ linux.dev/drivers/mtd/nand/Makefile 2006-12-14 04:38:51.000000000 +0100
+@@ -9,6 +9,7 @@
+ obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
+ obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-delta.o
+ obj-$(CONFIG_MTD_NAND_TOTO) += toto.o
++obj-$(CONFIG_MTD_NAND_RB500) += rbmipsnand.o
+ obj-$(CONFIG_MTD_NAND_AUTCPU12) += autcpu12.o
+ obj-$(CONFIG_MTD_NAND_EDB7312) += edb7312.o
+ obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o