aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2023-05-19 14:05:01 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-05-19 23:33:49 +0200
commitab7e2513034fe0e33ec17c13c8bf81189b0ce742 (patch)
tree78b6511aebc63e9a744093ec196bdc66436ab66a /target/linux/ramips
parent3a935f7ea9214c831eccc585f0677c5132957dde (diff)
downloadupstream-ab7e2513034fe0e33ec17c13c8bf81189b0ce742.tar.gz
upstream-ab7e2513034fe0e33ec17c13c8bf81189b0ce742.tar.bz2
upstream-ab7e2513034fe0e33ec17c13c8bf81189b0ce742.zip
ramips: fix build error on Airlink AR670W
The 'KERNEL' is not referenced by other objects, so double '$$' will cause shell unable to parse the variable 'BLOCKSIZE': dd ... bs=$(BLOCKSIZE) conv=sync bash: line 1: BLOCKSIZE: command not found Fixes: 09a0efbe83(ramips: set default BLOCKSIZE to 64k for nor flash devices) Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/rt288x.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index 3d2d0c7ae0..c93d7d78e5 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -15,7 +15,7 @@ define Device/airlink101_ar670w
DEVICE_VENDOR := Airlink
DEVICE_MODEL := AR670W
IMAGE_SIZE := 3840k
- KERNEL := $(KERNEL_DTB) | pad-to $$$$(BLOCKSIZE)
+ KERNEL := $(KERNEL_DTB) | pad-to $$(BLOCKSIZE)
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
wrg-header wrgn16a_airlink_ar670w