aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorAndreas Böhler <dev@aboehler.at>2023-04-02 10:40:47 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-06-08 15:33:14 +0200
commit0c885c1542382e737856864508448342fc61bb51 (patch)
tree60d3bfee0608638095620ff85bfcee730ac21e91 /target/linux/ramips
parentbb0306969134a5390b537465700175ed114c3427 (diff)
downloadupstream-0c885c1542382e737856864508448342fc61bb51.tar.gz
upstream-0c885c1542382e737856864508448342fc61bb51.tar.bz2
upstream-0c885c1542382e737856864508448342fc61bb51.zip
ramips: tplink,mr600v2: fix image generation for sysupgrade image
The MR600v2 does not find its rootfs if it is neither directly after the kernel or aligned to an erase block boundary (64k). This aligns the rootfs to 0x10000 allowing the device to boot again. Based on investigation by forum user relghuar. Signed-off-by: Andreas Böhler <dev@aboehler.at> (cherry picked from commit 46b51e9e992884c81f4838440cd2967e67db3a79)
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7621.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 6f50623acb..340d4ba4a1 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2160,6 +2160,9 @@ define Device/tplink_mr600-v2-eu
TPLINK_FLASHLAYOUT := 16Mltq
DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
kmod-usb-net-qmi-wwan uqmi kmod-usb3 -uboot-envtools
+ IMAGE/factory.bin := tplink-v2-image -e -a 0x10000
+ IMAGE/sysupgrade.bin := tplink-v2-image -s -e -a 0x10000 | check-size | \
+ append-metadata
KERNEL := $(KERNEL_DTB) | uImage lzma
KERNEL_INITRAMFS := $$(KERNEL) | tplink-v2-header
TPLINK_BOARD_ID := MR600-V2-EU