aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2023-02-17 08:12:40 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2023-03-17 17:22:53 -0300
commit4662adef2ad02dc5903516f69da017dcecf392c9 (patch)
treed41fcffca79a0ef3d2247f57cd44ec6b23896a26 /target/linux/ramips
parent6ac6f2402da7ced5b6295e446693a78179923fdd (diff)
downloadupstream-4662adef2ad02dc5903516f69da017dcecf392c9.tar.gz
upstream-4662adef2ad02dc5903516f69da017dcecf392c9.tar.bz2
upstream-4662adef2ad02dc5903516f69da017dcecf392c9.zip
uencrypt: add support for mbedtls
This commit includes some additional changes: - better handling of iv and keys in openssl/wolfssl variants - fix compiler warnings and whitespace - build all 3 variants as separate packages - adjust the new package name in targets' DEVICE_PACKAGES - remove PKG_FLAGS:=nonshared [Beeline SmartBox Flash - OK] Tested-by: Mikhail Zhilkin <csharper2005@gmail.com> [after test: replaced a hardcoded IV size of 16 by cipher_info->iv_size] Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7621.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 90b8bba2a5..07e63a5cf1 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -379,7 +379,7 @@ define Device/beeline_smartbox-flash
IMAGES += factory.trx
IMAGE/factory.trx := append-kernel | append-ubi | check-size
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- DEVICE_PACKAGES := kmod-usb3 kmod-mt7615-firmware uencrypt
+ DEVICE_PACKAGES := kmod-usb3 kmod-mt7615-firmware uencrypt-mbedtls
endef
TARGET_DEVICES += beeline_smartbox-flash
@@ -1587,7 +1587,7 @@ define Device/mts_wg430223
IMAGES += factory.trx
IMAGE/factory.trx := append-kernel | append-ubi | check-size
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- DEVICE_PACKAGES := kmod-mt7615-firmware uencrypt
+ DEVICE_PACKAGES := kmod-mt7615-firmware uencrypt-mbedtls
endef
TARGET_DEVICES += mts_wg430223