aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorMikhail Zhilkin <csharper2005@gmail.com>2022-04-28 18:24:07 +0000
committerChuanhong Guo <gch981213@gmail.com>2022-06-13 15:26:23 +0800
commit109c503bee9aed34ffb485a29af1e2ec6f3bb6b1 (patch)
tree53da72955aaf7cb19503eb20dd809edd3758c128 /target/linux/ramips
parent857ea3f690aba8513b356926d9c430adafc7c50b (diff)
downloadupstream-109c503bee9aed34ffb485a29af1e2ec6f3bb6b1.tar.gz
upstream-109c503bee9aed34ffb485a29af1e2ec6f3bb6b1.tar.bz2
upstream-109c503bee9aed34ffb485a29af1e2ec6f3bb6b1.zip
ramips: allow custom trx magic for Arcadyan
This commit: 1. Renames beeline-trx recipe in mt7621.mk to arcadyan-trx. The recipe is necessary for: - MTS WG430223 (Arcadyan WG430223) - Beeline Smartbox Flash (Arcadyan WG443223) 2. Allows specify custom trx magic which is different for the routers mentined above. Signed-off-by: Mikhail Zhilkin <csharper2005@gmail.com>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index a485a5043a..6ea827b41c 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -13,9 +13,10 @@ ifdef CONFIG_LINUX_5_10
DTS_CPPFLAGS += -DDTS_LEGACY
endif
-define Build/beeline-trx
+define Build/arcadyan-trx
echo -ne "hsqs" > $@.hsqs
- $(STAGING_DIR_HOST)/bin/otrx create $@.trx -M 0x746f435d -f $@ \
+ $(eval trx_magic=$(word 1,$(1)))
+ $(STAGING_DIR_HOST)/bin/otrx create $@.trx -M $(trx_magic) -f $@ \
-a 0x20000 -b 0x420000 -f $@.hsqs -a 1000
mv $@.trx $@
dd if=/dev/zero bs=1024 count=1 >> $@.tail
@@ -242,7 +243,7 @@ define Device/beeline_smartbox-flash
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | \
- uImage none | beeline-trx | pad-to $$(KERNEL_SIZE)
+ uImage none | arcadyan-trx 0x746f435d | pad-to $$(KERNEL_SIZE)
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel | \
uImage none
IMAGES += factory.trx