aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2022-11-05 19:52:08 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-12 21:55:11 +0100
commitd2ae7613b5749e8a4b63e23c9b58eb5f5ffeed06 (patch)
tree9c221f9fe09fad97fd60726805301380933d721e /target/linux/ramips
parent9155d405130041e9abaf1fcbc03dd7f6746a1fc9 (diff)
downloadupstream-d2ae7613b5749e8a4b63e23c9b58eb5f5ffeed06.tar.gz
upstream-d2ae7613b5749e8a4b63e23c9b58eb5f5ffeed06.tar.bz2
upstream-d2ae7613b5749e8a4b63e23c9b58eb5f5ffeed06.zip
ramips: improve compatibility for Youku YK-L2 and YK-L1 series
Add UIMAGE_NAME and UIMAGE_MAGIC to allow users to directly install initramfs-kernel.bin from the stock firmware Web UI. At the same time, this change makes it possible to boot OpenWrt with the official u-boot. Notice: Since the stock firmware is based on OpenWrt and the configuration will be retained by default during the upgrade process, so we must use initramfs-kernel.bin to do a initial installation. After the system restarts, install sysupgrade.bin and do not retain any configuration. Signed-off-by: Shiji Yang <yangshiji66@qq.com> (cherry picked from commit eba0a8deb65de70b0d913f9ec8910640a79d0191)
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/dts/mt7620a_youku_yk-l1.dtsi3
-rw-r--r--target/linux/ramips/dts/mt7621_youku_yk-l2.dts3
-rw-r--r--target/linux/ramips/image/mt7620.mk4
-rw-r--r--target/linux/ramips/image/mt7621.mk2
4 files changed, 10 insertions, 2 deletions
diff --git a/target/linux/ramips/dts/mt7620a_youku_yk-l1.dtsi b/target/linux/ramips/dts/mt7620a_youku_yk-l1.dtsi
index d15d2c0f4b..210b0d7d19 100644
--- a/target/linux/ramips/dts/mt7620a_youku_yk-l1.dtsi
+++ b/target/linux/ramips/dts/mt7620a_youku_yk-l1.dtsi
@@ -86,8 +86,9 @@
};
firmware: partition@50000 {
- compatible = "denx,uimage";
+ compatible = "openwrt,uimage", "denx,uimage";
label = "firmware";
+ openwrt,ih-magic = <0x12291000>;
/* reg property is set based on flash size in DTS files */
};
};
diff --git a/target/linux/ramips/dts/mt7621_youku_yk-l2.dts b/target/linux/ramips/dts/mt7621_youku_yk-l2.dts
index 19ba7c08de..96e0b73bdd 100644
--- a/target/linux/ramips/dts/mt7621_youku_yk-l2.dts
+++ b/target/linux/ramips/dts/mt7621_youku_yk-l2.dts
@@ -95,8 +95,9 @@
};
partition@50000 {
- compatible = "denx,uimage";
+ compatible = "openwrt,uimage", "denx,uimage";
label = "firmware";
+ openwrt,ih-magic = <0x12291000>;
reg = <0x50000 0xfb0000>;
};
};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index d2a2c90460..6089750407 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -1256,6 +1256,8 @@ define Device/youku_yk-l1
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 \
kmod-usb-ledtrig-usbport
SUPPORTED_DEVICES += youku-yk1 youku,yk1
+ UIMAGE_MAGIC := 0x12291000
+ UIMAGE_NAME := 400000000000000000000000
endef
TARGET_DEVICES += youku_yk-l1
@@ -1266,6 +1268,8 @@ define Device/youku_yk-l1c
DEVICE_MODEL := YK-L1c
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 \
kmod-usb-ledtrig-usbport
+ UIMAGE_MAGIC := 0x12291000
+ UIMAGE_NAME := 400000000000000000000000
endef
TARGET_DEVICES += youku_yk-l1c
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index adf8382002..4057c4ea11 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2079,6 +2079,8 @@ define Device/youku_yk-l2
DEVICE_MODEL := YK-L2
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 \
kmod-usb-ledtrig-usbport
+ UIMAGE_MAGIC := 0x12291000
+ UIMAGE_NAME := 400000000000000000003000
endef
TARGET_DEVICES += youku_yk-l2