aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorSeo Suchan <abnoeh@mail.com>2021-02-18 00:06:55 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-19 20:09:28 +0100
commit800a568df51c64fab42ed0622b5b7f3d5e46844a (patch)
tree58d9d8680acba3e72172a275f7e19697ec12d7d7 /target/linux/ramips
parenta7c0c9bb7ec3de79a11e7bf7facf8369235e74a5 (diff)
downloadupstream-800a568df51c64fab42ed0622b5b7f3d5e46844a.tar.gz
upstream-800a568df51c64fab42ed0622b5b7f3d5e46844a.tar.bz2
upstream-800a568df51c64fab42ed0622b5b7f3d5e46844a.zip
ramips: use lzma-loader for Wevo devices
As kernel size increased it start to fail to load squishfs image, using lzma-loader fixed it. wevo_11acnas is almost same device as w2914ns-v2 except ram size, so I expect same thing would've happen in that device too. Signed-off-by: Seo Suchan <abnoeh@mail.com> Reviewed-by: Sungbo Eo <mans0n@gorani.run> (cherry picked from commit ca6954e2dc3faa32eec54b93bda996c874409675)
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7621.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index a4edf0a6df..396b112b76 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1254,6 +1254,7 @@ TARGET_DEVICES += wavlink_wl-wn531a6
define Device/wevo_11acnas
$(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 16064k
UIMAGE_NAME := 11AC-NAS-Router(0.0.0)
DEVICE_VENDOR := WeVO
@@ -1266,6 +1267,7 @@ TARGET_DEVICES += wevo_11acnas
define Device/wevo_w2914ns-v2
$(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 16064k
UIMAGE_NAME := W2914NS-V2(0.0.0)
DEVICE_VENDOR := WeVO