aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-08-27 23:55:12 +0200
committerDavid Bauer <mail@david-bauer.net>2019-09-16 21:43:39 +0200
commit250d57ac29b8cf3a98387f4a25cc371e27ddad87 (patch)
tree24060bf850187f07cff8c56ce75aae537ba1ef69 /target/linux/ramips
parent11644ec8e1b91c3ff51ba09f535e55dfd0c65d62 (diff)
downloadupstream-250d57ac29b8cf3a98387f4a25cc371e27ddad87.tar.gz
upstream-250d57ac29b8cf3a98387f4a25cc371e27ddad87.tar.bz2
upstream-250d57ac29b8cf3a98387f4a25cc371e27ddad87.zip
ramips: add factory image for NETGEAR R6220
This adds an easy-installation factory image for the NETGEAR R6220 router. The factory image can either be flashed via the vendor Web-UI or the bootloader using nmrpflash. Tested with NETGEAR V1.1.0.86 firmware. Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 607dfdf211bebb5043cbc0267c1e2c3e3c2514b4)
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d125fdc04d..aab6097d33 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -322,7 +322,12 @@ define Device/r6220
KERNEL_SIZE := 4096k
IMAGE_SIZE := 28672k
UBINIZE_OPTS := -E 5
- IMAGES += kernel.bin rootfs.bin
+ SERCOMM_HWID := AYA
+ SERCOMM_HWVER := A001
+ SERCOMM_SWVER := 0x0086
+ IMAGES += factory.img kernel.bin rootfs.bin
+ IMAGE/factory.img := pad-extra 2048k | append-kernel | pad-to 6144k | append-ubi | \
+ pad-to $$$$(BLOCKSIZE) | sercom-footer | pad-to 128 | zip R6220.bin | sercom-seal
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/kernel.bin := append-kernel
IMAGE/rootfs.bin := append-ubi | check-size $$$$(IMAGE_SIZE)