aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-05-29 11:28:10 +0000
committerJohn Crispin <blogic@openwrt.org>2015-05-29 11:28:10 +0000
commitb15b638a588762ac41ab3f944d37684734a1a078 (patch)
tree4a235980457208cd5ee155ce1c0249d3f43bf260 /target/linux/ramips
parent38148fdba1d31e0281c8ed92aec4cc720007e834 (diff)
downloadupstream-b15b638a588762ac41ab3f944d37684734a1a078.tar.gz
upstream-b15b638a588762ac41ab3f944d37684734a1a078.tar.bz2
upstream-b15b638a588762ac41ab3f944d37684734a1a078.zip
ramips: fix imagebuilder
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45820 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 422366c098..4ae9ca4f2b 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -62,7 +62,7 @@ endef
define Build/relocate-kernel
( \
- dd if=$(KDIR)/relocate/loader.bin bs=32 conv=sync && \
+ dd if=$(KDIR)/loader.bin bs=32 conv=sync && \
perl -e '@s = stat("$@"); print pack("V", @s[7])' && \
cat $@ \
) > $@.new
@@ -989,10 +989,12 @@ endef
endif
ifeq ($(SUBTARGET),mt7621)
-define Build/Compile
+define Image/Prepare
+#define Build/Compile
rm -rf $(KDIR)/relocate
$(CP) ../../generic/image/relocate $(KDIR)
$(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
+ $(CP) $(KDIR)/relocate/loader.bin $(KDIR)/loader.bin
endef
endif