aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-27 14:56:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-27 14:56:22 +0000
commit6ad2228969084b81bf5b69a88d987b564fe03a99 (patch)
tree6458b070d111a9915cad2b4639b7cd721ec9fd8d /target/linux/ramips
parentc3e4dc503991873b627fc6a5951a6049b4e4cfb9 (diff)
downloadupstream-6ad2228969084b81bf5b69a88d987b564fe03a99.tar.gz
upstream-6ad2228969084b81bf5b69a88d987b564fe03a99.tar.bz2
upstream-6ad2228969084b81bf5b69a88d987b564fe03a99.zip
ramips: check size after padding
Signed-off-by: Cristian Morales Vega <cristian@samknows.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45777 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index b0b35796a7..422366c098 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -35,7 +35,7 @@ define Device/Default
KERNEL := $(KERNEL_DTB) | uImage lzma
IMAGES := sysupgrade.bin
IMAGE_SIZE := $(ralink_default_fw_size_8M)
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | check-size $$$$(IMAGE_SIZE) | pad-rootfs
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
define Build/patch-dtb