aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-04-30 10:43:59 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-04-30 10:43:59 +0000
commitf718179af5ddfd944a3adcdc7a9b43c56f2f9bcb (patch)
tree2b361e73747aaa7076fac339d362d1e3c951e32f /target/linux/ramips
parent8e466dcdf4f391b8940148e8a0431a5a8c608584 (diff)
downloadupstream-f718179af5ddfd944a3adcdc7a9b43c56f2f9bcb.tar.gz
upstream-f718179af5ddfd944a3adcdc7a9b43c56f2f9bcb.tar.bz2
upstream-f718179af5ddfd944a3adcdc7a9b43c56f2f9bcb.zip
kernel: update linux 3.8 to 3.8.10
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 36493
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/Makefile2
-rw-r--r--target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index 1b359ad06b..f4a4212765 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
FEATURES:=squashfs gpio
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\
diff --git a/target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch b/target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch
index 8f6899c4cc..f15d16f6da 100644
--- a/target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch
+++ b/target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch
@@ -25,7 +25,7 @@ Subject: [PATCH 19/25] owrt mtd split
---help---
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -844,6 +844,99 @@ static int refresh_rootfs_split(struct m
+@@ -833,6 +833,99 @@ static int refresh_rootfs_split(struct m
}
#endif /* CONFIG_MTD_ROOTFS_SPLIT */
@@ -125,7 +125,7 @@ Subject: [PATCH 19/25] owrt mtd split
/*
* This function, given a master MTD object and a partition table, creates
* and registers slave MTD objects which are bound to the master according to
-@@ -860,7 +953,7 @@ int add_mtd_partitions(struct mtd_info *
+@@ -849,7 +942,7 @@ int add_mtd_partitions(struct mtd_info *
struct mtd_part *slave;
uint64_t cur_offset = 0;
int i;
@@ -134,7 +134,7 @@ Subject: [PATCH 19/25] owrt mtd split
int ret;
#endif
-@@ -877,6 +970,14 @@ int add_mtd_partitions(struct mtd_info *
+@@ -866,6 +959,14 @@ int add_mtd_partitions(struct mtd_info *
add_mtd_device(&slave->mtd);