aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorAlexey Belyaev <spider@spider.vc>2017-04-28 00:02:05 +0600
committerMathias Kresin <dev@kresin.me>2017-05-10 08:45:12 +0200
commita7cbf59e0e04a24b91a112e9b2e1a72ed5b4c1f6 (patch)
tree3db09931e0d2fc603c7b55d0a9963262c84163e4 /target/linux/ramips
parent54ea0f45c8b375ff29478c1f0d659d1548e89fc9 (diff)
downloadupstream-a7cbf59e0e04a24b91a112e9b2e1a72ed5b4c1f6.tar.gz
upstream-a7cbf59e0e04a24b91a112e9b2e1a72ed5b4c1f6.tar.bz2
upstream-a7cbf59e0e04a24b91a112e9b2e1a72ed5b4c1f6.zip
ramips: add new device ZyXEL Keenetic as kn
This device exactly same as NBG-419N but with USB port and USB Led. Specification: - SoC: Ralink RT3052 (MIPS24Kc) @384MHz - RAM: 32 MiB - Flash: 8 MiB - WLAN: WiSoC 2T2R/300Mbps (2.4GHz) - LAN: 4x100M - WAN: 1x100M - USB: 1x2.0 Installation via serial console (57600 8N1) from TFTP server - rename the firmware to something shorter, for example "sysupgrade.bin" (max. 32 chars) - copy firmware TFTP server's directory - when you power on device, and see U-Boot log, immediatly push "2" once. - You will see this message: 2: System Load Linux Kernel then write to Flash via TFTP. Warning!! Erase Linux in Flash then burn new one. Are you sure? - Push "y", and enter: device IP, then TFTP server's IP, and then image firmware file name. The firmware will be downloaded within ~30 seconds and flashed to the device (It will take about 2 minutes). Signed-off-by: Alexey Belyaev <spider@spider.vc> [squash commits, compact commit message, fix compatible string, remove superfluous pinmuxes] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds9
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/kn.dts113
-rw-r--r--target/linux/ramips/image/rt305x.mk9
7 files changed, 133 insertions, 4 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 52542ec265..9322228a10 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -222,6 +222,11 @@ ht-tm02)
ucidef_set_led_netdev "eth" "Ethernet" "$board:green:lan" "eth0"
set_wifi_led "$board:blue:wlan"
;;
+kn|\
+nbg-419n2)
+ set_usb_led "$board:green:usb"
+ set_wifi_led "rt2800pci-phy0::radio"
+ ;;
kn_rc|\
kn_rf|\
kng_rc)
@@ -265,10 +270,6 @@ mzk-ex750np)
na930)
set_usb_led "$board:blue:status"
;;
-nbg-419n2)
- set_usb_led "$board:green:usb"
- set_wifi_led "rt2800pci-phy0::radio"
- ;;
newifi-d1)
set_usb_led "$board:red:status"
;;
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 80a3bc2c51..cefc4f41fe 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -84,6 +84,7 @@ ramips_setup_interfaces()
hc5661a|\
hc5962|\
hlk-rm04|\
+ kn|\
kn_rc|\
mac1200rv2|\
miwifi-mini|\
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index 461f46c26b..a36ce54675 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -24,6 +24,7 @@ get_status_led() {
e1700|\
ex3700|\
fonera20n|\
+ kn|\
kn_rc|\
kn_rf|\
kng_rc|\
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 87cb7ffb91..506a98230a 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -670,6 +670,9 @@ ramips_board_detect() {
*"ZBT-WR8305RT")
name="zbt-wr8305rt"
;;
+ *"ZyXEL Keenetic")
+ name="kn"
+ ;;
*"ZyXEL Keenetic Omni")
name="kn_rc"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index adad8dae75..039009303b 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -76,6 +76,7 @@ platform_check_image() {
jhr-n805r|\
jhr-n825r|\
jhr-n926r|\
+ kn|\
kn_rc|\
kn_rf|\
kng_rc|\
diff --git a/target/linux/ramips/dts/kn.dts b/target/linux/ramips/dts/kn.dts
new file mode 100644
index 0000000000..77b047c094
--- /dev/null
+++ b/target/linux/ramips/dts/kn.dts
@@ -0,0 +1,113 @@
+/dts-v1/;
+
+#include "rt3050.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "zyxel,keenetic", "ralink,rt3052-soc";
+ model = "ZyXEL Keenetic";
+
+ cfi@1f000000 {
+ compatible = "cfi-flash";
+ reg = <0x1f000000 0x800000>;
+ bank-width = <2>;
+ device-width = <2>;
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x3b0000>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ power {
+ label = "kn:green:power";
+ gpios = <&gpio0 9 GPIO_ACTIVE_LOW>;
+ };
+
+ usb {
+ label = "kn:green:usb";
+ gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+ };
+
+ wps {
+ label = "kn:green:wps";
+ gpios = <&gpio0 14 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ rfkill {
+ label = "rfkill";
+ gpios = <&gpio0 12 GPIO_ACTIVE_HIGH>;
+ linux,code = <KEY_RFKILL>;
+ linux,input-type = <EV_SW>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio0 0 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+ };
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "uartf";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x28>;
+};
+
+&esw {
+ mediatek,portmap = <0x2f>;
+};
+
+&wmac {
+ ralink,mtd-eeprom = <&factory 0>;
+};
+
+&otg {
+ status = "okay";
+};
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 69533ce9e7..62ced9b7de 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -850,3 +850,12 @@ define Device/xdxrn502j
DEVICE_TITLE := XDX RN502J
endef
TARGET_DEVICES += xdxrn502j
+
+define Device/kn
+ DTS := kn
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ DEVICE_TITLE := ZyXEL Keenetic
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += kn