aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-03-03 13:57:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-03-03 13:57:40 +0000
commit23b3b3a194bc56307bfb2f371612e0b5ef881b98 (patch)
treed65a523d9a6df4858bc88b1aaffe235150fcfc59 /target/linux/ramips
parentb58bd6e8811f3db0fb254e25a4c886c9e48c80c7 (diff)
downloadupstream-23b3b3a194bc56307bfb2f371612e0b5ef881b98.tar.gz
upstream-23b3b3a194bc56307bfb2f371612e0b5ef881b98.tar.bz2
upstream-23b3b3a194bc56307bfb2f371612e0b5ef881b98.zip
kernel: update linux 3.7 to 3.7.10
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35860
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/Makefile2
-rw-r--r--target/linux/ramips/patches-3.7/a01-revert-ehci-port_power_off-removal.patch9
2 files changed, 5 insertions, 6 deletions
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index b02c8016ed..80cc960fa5 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
FEATURES:=squashfs
-LINUX_VERSION:=3.7.9
+LINUX_VERSION:=3.7.10
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\
diff --git a/target/linux/ramips/patches-3.7/a01-revert-ehci-port_power_off-removal.patch b/target/linux/ramips/patches-3.7/a01-revert-ehci-port_power_off-removal.patch
index ad2645a12d..c4d12f13d5 100644
--- a/target/linux/ramips/patches-3.7/a01-revert-ehci-port_power_off-removal.patch
+++ b/target/linux/ramips/patches-3.7/a01-revert-ehci-port_power_off-removal.patch
@@ -1,7 +1,7 @@
reverted:
--- a/arch/mips/ralink/rt3883/devices.c
+++ b/arch/mips/ralink/rt3883/devices.c
-@@ -177,6 +177,7 @@
+@@ -177,6 +177,7 @@ static void rt3883_usb_power_off(struct
}
static struct usb_ehci_pdata rt3883_ehci_data = {
@@ -9,10 +9,9 @@ reverted:
.power_on = rt3883_usb_power_on,
.power_off = rt3883_usb_power_off,
};
-reverted:
---- b/arch/mips/ralink/rt305x/devices.c
-+++ a/arch/mips/ralink/rt305x/devices.c
-@@ -356,6 +356,7 @@
+--- a/arch/mips/ralink/rt305x/devices.c
++++ b/arch/mips/ralink/rt305x/devices.c
+@@ -356,6 +356,7 @@ static void rt3352_usb_power_off(struct
}
static struct usb_ehci_pdata rt3352_ehci_data = {