aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-23 07:14:42 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-23 07:14:42 +0000
commita0f7da3b8c8b6abc682305e92a26c794e33fd670 (patch)
treebe9ba20c88e6e97f598e059da294feddaee08474 /target/linux/ramips
parentfcfb5c515a931d83c1637527df6f54532619c3c4 (diff)
downloadupstream-a0f7da3b8c8b6abc682305e92a26c794e33fd670.tar.gz
upstream-a0f7da3b8c8b6abc682305e92a26c794e33fd670.tar.bz2
upstream-a0f7da3b8c8b6abc682305e92a26c794e33fd670.zip
CC: ramips: Backport support for ZBT WG2626
Backport of r47351 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47605 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds5
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh5
-rw-r--r--target/linux/ramips/dts/ZBT-WG2626.dts127
-rw-r--r--target/linux/ramips/image/Makefile7
-rw-r--r--target/linux/ramips/mt7621/profiles/zbt.mk19
8 files changed, 168 insertions, 4 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 545bd7090a..5946f98bdb 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -258,6 +258,11 @@ case $board in
set_usb_led "lenovo:blue:usb"
set_wifi_led "lenovo:blue:wifi"
;;
+ zbt-wg2626)
+ ucidef_set_led_default "power" "power" "zbt-wg2626:green:power" "1"
+ set_wifi_led "zbt-wg2626:green:air"
+ set_usb_led "zbt-wg2626:green:usb"
+ ;;
zte-q7)
set_wifi_led "zte:blue:status"
;;
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 19ef3f739c..d7d016befe 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -145,7 +145,8 @@ ramips_setup_interfaces()
wsr-1166 | \
wt1520 | \
xiaomi-miwifi-mini |\
- y1)
+ y1|\
+ zbt-wg2626)
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
ucidef_add_switch "switch0" "1" "1"
ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 6t"
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index d32d69288b..0747d703f1 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -247,6 +247,9 @@ get_status_led() {
y1s)
status_led="lenovo:blue:power"
;;
+ zbt-wg2626)
+ status_led="zbt-wg2626:green:power"
+ ;;
zte-q7)
status_led="zte:red:status"
;;
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index a9a6664056..4141ddd68b 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -403,6 +403,9 @@ ramips_board_detect() {
*"Zbtlink ZBT-WA05")
name="zbt-wa05"
;;
+ *"ZBT-WG2626")
+ name="zbt-wg2626"
+ ;;
*"ZBT WR8305RT")
name="wr8305rt"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 11fee85ea1..2f64d8c0c4 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -126,8 +126,9 @@ platform_check_image() {
xiaomi-miwifi-mini |\
y1 |\
y1s |\
- zte-q7 |\
- zbt-wa05)
+ zbt-wa05 |\
+ zbt-wg2626 |\
+ zte-q7)
[ "$magic" != "27051956" ] && {
echo "Invalid image type."
return 1
diff --git a/target/linux/ramips/dts/ZBT-WG2626.dts b/target/linux/ramips/dts/ZBT-WG2626.dts
new file mode 100644
index 0000000000..6170454bc6
--- /dev/null
+++ b/target/linux/ramips/dts/ZBT-WG2626.dts
@@ -0,0 +1,127 @@
+/dts-v1/;
+
+/include/ "mt7621.dtsi"
+
+/ {
+ compatible = "mediatek,mt7621-eval-board", "mediatek,mt7621-soc";
+ model = "ZBT-WG2626";
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x1c000000>, <0x20000000 0x4000000>;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ sdhci@10130000 {
+ status = "okay";
+ };
+
+ palmbus@1E000000 {
+ spi@b00 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "w25q128";
+ reg = <0 0>;
+ linux,modalias = "m25p80";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+
+ };
+ };
+
+ i2c@900 {
+ compatible = "ralink,i2c-mt7621";
+ reg = <0x900 0x100>;
+ #address-cells = <1>;
+ #size-cells = <0>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&i2c_pins>;
+ status = "okay";
+ };
+ };
+
+ pcie@1e140000 {
+ status = "okay";
+
+ pcie0 {
+ mt76@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ device_type = "pci";
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ mediatek,2ghz = <0>;
+ };
+ };
+
+ pcie1 {
+ mt76@1,0 {
+ reg = <0x0000 0 0 0 0>;
+ device_type = "pci";
+ mediatek,mtd-eeprom = <&factory 0x0000>;
+ mediatek,5ghz = <0>;
+ };
+ };
+ };
+
+ ethernet@1e100000 {
+ mtd-mac-address = <&factory 0xe000>;
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 18 1>;
+ linux,code = <0x198>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ status {
+ label = "zbt-wg2626:green:status";
+ gpios = <&gpio0 24 1>;
+ };
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "wdt", "rgmii2", "wdt rst", "jtag", "mdio";
+ ralink,function = "gpio";
+ };
+ };
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index b4d0897780..0dd46ca19c 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -928,7 +928,7 @@ endif
#
ifeq ($(SUBTARGET),mt7621)
- TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500
+ TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 zbt-wg2626
endif
define Device/mt7621
@@ -974,6 +974,11 @@ define Device/pbr-m1
IMAGE_SIZE := $(ralink_default_fw_size_16M)
endef
+define Device/zbt-wg2626
+ DTS := ZBT-WG2626
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+endef
+
#
# MT7628 Profiles
#
diff --git a/target/linux/ramips/mt7621/profiles/zbt.mk b/target/linux/ramips/mt7621/profiles/zbt.mk
new file mode 100644
index 0000000000..cf9beffd10
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/zbt.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZBT-WG2626
+ NAME:=ZBT-WG2626 Device
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
+ kmod-usb3-mt7621
+endef
+
+define Profile/ZBT-WG2626/Description
+ Package set for ZBT-WG2626 device
+endef
+$(eval $(call Profile,ZBT-WG2626))