aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-19 17:52:08 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-19 17:52:08 +0000
commita9168c816d974f479de25dc9c1395c31100b4b04 (patch)
treeea869b968b08d8f3c8cf474d13d1e8c35589f82d /target/linux/ramips
parent75603b2e322374f57b05a60f3f0803be43800800 (diff)
downloadupstream-a9168c816d974f479de25dc9c1395c31100b4b04.tar.gz
upstream-a9168c816d974f479de25dc9c1395c31100b4b04.tar.bz2
upstream-a9168c816d974f479de25dc9c1395c31100b4b04.zip
ramips: build sysupgrade image for the V11ST-FE board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30648 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 588dfa55fb..770b12e62e 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -353,6 +353,11 @@ define Image/Build/Profile/RTN15
$(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
endef
+mtdlayout_v11stfe=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,1280k(kernel),2112k(rootfs),3392k@0x50000(firmware)
+define Image/Build/Profile/V11STFE
+ $(call BuildFirmware/Generic,$(1),v11st-fe,board=V11ST-FE,mtdlayout_v11stfe,1310720,2162688)
+endef
+
mtdlayout_wlitx4ag300n=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2880k(rootfs),64k(user)ro,3712k@0x50000(firmware)
define Image/Build/Profile/WLITX4AG300N
$(call BuildFirmware/Buffalo2,$(1),wli-tx4-ag300n,WLI-TX4-AG300N,mtdlayout_wlitx4ag300n,851968,2949120)
@@ -362,6 +367,7 @@ ifeq ($(CONFIG_RALINK_RT288X),y)
define Image/Build/Profile/Default
$(call Image/Build/Profile/F5D8235V1,$(1))
$(call Image/Build/Profile/RTN15,$(1))
+ $(call Image/Build/Profile/V11STFE,$(1))
$(call Image/Build/Profile/WLITX4AG300N,$(1))
endef
endif