aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-21 09:44:30 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-21 09:44:30 +0000
commit95b3aa418cfab1eb3d8d583e6ea6c0f97266f93f (patch)
tree610cfcad7ec9a6faf9a648df080f5342f49fbb17 /target/linux/ramips
parent1cd6916f8fd2925c54dc95ce789b844557064be7 (diff)
downloadupstream-95b3aa418cfab1eb3d8d583e6ea6c0f97266f93f.tar.gz
upstream-95b3aa418cfab1eb3d8d583e6ea6c0f97266f93f.tar.bz2
upstream-95b3aa418cfab1eb3d8d583e6ea6c0f97266f93f.zip
ramips: raeth: add missing Kconfig and Makefile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30671 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/files/drivers/net/ethernet/ramips/Kconfig13
-rw-r--r--target/linux/ramips/files/drivers/net/ethernet/ramips/Makefile5
2 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/files/drivers/net/ethernet/ramips/Kconfig b/target/linux/ramips/files/drivers/net/ethernet/ramips/Kconfig
new file mode 100644
index 0000000000..08d7ad170c
--- /dev/null
+++ b/target/linux/ramips/files/drivers/net/ethernet/ramips/Kconfig
@@ -0,0 +1,13 @@
+config NET_RAMIPS
+ tristate "Ralink RT288X/RT3X5X/RT3662/RT3883 ethernet driver"
+ depends on MIPS_RALINK
+ select PHYLIB if (SOC_RT288X || SOC_RT3883)
+ help
+ This driver supports the etehrnet mac inside the ralink wisocs
+
+if NET_RAMIPS
+
+config NET_RAMIPS_DEBUG
+ bool "Enable debug messages in the Ralink ethernet driver"
+
+endif
diff --git a/target/linux/ramips/files/drivers/net/ethernet/ramips/Makefile b/target/linux/ramips/files/drivers/net/ethernet/ramips/Makefile
new file mode 100644
index 0000000000..db4a58f0e9
--- /dev/null
+++ b/target/linux/ramips/files/drivers/net/ethernet/ramips/Makefile
@@ -0,0 +1,5 @@
+#
+# Makefile for the Ramips SoCs built-in ethernet macs
+#
+
+obj-$(CONFIG_NET_RAMIPS) += ramips.o