aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:49 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:49 +0000
commit9956d339e9803f3808473453071464acd5aa0fb1 (patch)
tree4eb4bcc85d38052f6ef359033c93afbc90c4211b /target/linux/ramips/rt305x
parent8ef1c93002fd8a04903e6bba1a2dea018bd6af28 (diff)
downloadupstream-9956d339e9803f3808473453071464acd5aa0fb1.tar.gz
upstream-9956d339e9803f3808473453071464acd5aa0fb1.tar.bz2
upstream-9956d339e9803f3808473453071464acd5aa0fb1.zip
ramips: Add support for VoCore
This is based and tested on VoCore Alpha, but other stuff like status/eth LEDs are present on the final board revision + VoDock. All GPIOs are exported, except spi/i2c. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Backport of r41939 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42376 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/vocore.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/vocore.mk b/target/linux/ramips/rt305x/profiles/vocore.mk
new file mode 100644
index 0000000000..11fb634beb
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/vocore.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/VOCORE
+ NAME:=VoCore
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-i2c-core kmod-i2c-ralink
+endef
+
+define Profile/VOCORE/Description
+ Package set for VoCore board
+endef
+
+$(eval $(call Profile,VOCORE))