aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorL. D. Pinney <ldpinney@gmail.com>2016-07-06 19:24:52 -0500
committerJohn Crispin <john@phrozen.org>2016-07-11 14:19:47 +0200
commitcf8c77be6becf3c5e40e19e9c4ab0d0abdfb9291 (patch)
treeaff54a5e720a3452141a9a133e74df06a4044d17 /target/linux/ramips/rt305x
parent88765756013548cc86cb95c585e22079622b588c (diff)
downloadupstream-cf8c77be6becf3c5e40e19e9c4ab0d0abdfb9291.tar.gz
upstream-cf8c77be6becf3c5e40e19e9c4ab0d0abdfb9291.tar.bz2
upstream-cf8c77be6becf3c5e40e19e9c4ab0d0abdfb9291.zip
ramips: Add support for the NixCore X1 Module
The NixCore X1 is a Ralink/MediaTek rt5350 WiFi Module. http://nixcores.com/ Signed-off-by: L. D. Pinney <ldpinney@gmail.com> Acked-by: Drew Gaylo <drew@nixcores.com>
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/nixcore.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/nixcore.mk b/target/linux/ramips/rt305x/profiles/nixcore.mk
new file mode 100644
index 0000000000..475053c934
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/nixcore.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2016 lede-project.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NIXCORE
+ NAME:=NixcoreX1
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-i2c-core kmod-i2c-ralink \
+ kmod-spi-dev
+endef
+
+define Profile/NIXCORE/Description
+ Package set for Nixcore X1 board
+endef
+
+$(eval $(call Profile,NIXCORE))