aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-04-25 19:03:01 +0000
committerJohn Crispin <john@openwrt.org>2013-04-25 19:03:01 +0000
commitcf3885eb0f276f3d0a12aeeff3445799b59fbb23 (patch)
tree257257f55ccc93c29cd6d68abb1cc3a225c52579 /target/linux/ramips/rt305x
parent978567a89e3a1460f0fc1e9d39c7b70548de6629 (diff)
downloadupstream-cf3885eb0f276f3d0a12aeeff3445799b59fbb23.tar.gz
upstream-cf3885eb0f276f3d0a12aeeff3445799b59fbb23.tar.bz2
upstream-cf3885eb0f276f3d0a12aeeff3445799b59fbb23.zip
ramips: introduce DTS for ALL5003
Prior to the switch to 3.8, ALL5002 and ALL5003 boards shared mach-all5002.c. With the change to DTS, this is no longer accurate, as ALL5002 is based on Rt3352 SoC while ALL5003 is based on Rt5350 SoC, therefore the corresponding rt5350.dtsi need to be included for ALL5003. Signed-off-by: Daniel Golle <dgolle@allnet.de> Patchwork: http://patchwork.openwrt.org/patch/3557/ Acked-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36435
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/allnet.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/allnet.mk b/target/linux/ramips/rt305x/profiles/allnet.mk
index 4ec2ffdd5c..858891f4d4 100644
--- a/target/linux/ramips/rt305x/profiles/allnet.mk
+++ b/target/linux/ramips/rt305x/profiles/allnet.mk
@@ -40,3 +40,15 @@ define Profile/ALL5002/Description
endef
$(eval $(call Profile,ALL5002))
+
+define Profile/ALL5003
+ NAME:=Allnet ALL5003
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+ kmod-i2c-core kmod-i2c-gpio kmod-hwmon-lm92 kmod-gpio-pcf857x
+endef
+
+define Profile/ALL5003/Description
+ Package set for Allnet ALL5003
+endef
+
+$(eval $(call Profile,ALL5003))