aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-23 16:56:06 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-23 16:56:06 +0000
commit1ab80c78171515cd6181d6eeb0a33dda2f7442e3 (patch)
treec843a0b733c81f4869e2424642ac2da6e410740e /target/linux/ramips/rt305x
parent3626444c6d4f6de3905a218061b16421870d580a (diff)
downloadupstream-1ab80c78171515cd6181d6eeb0a33dda2f7442e3.tar.gz
upstream-1ab80c78171515cd6181d6eeb0a33dda2f7442e3.tar.bz2
upstream-1ab80c78171515cd6181d6eeb0a33dda2f7442e3.zip
ramips: rt305x: add support for the UR-336UN board
Patch-by: Lebedev Dmitry <lebedev@trendnet.ru> SVN-Revision: 31451
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/config-3.31
-rw-r--r--target/linux/ramips/rt305x/profiles/upvel.mk18
2 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/config-3.3 b/target/linux/ramips/rt305x/config-3.3
index bea6349263..0b47fcac01 100644
--- a/target/linux/ramips/rt305x/config-3.3
+++ b/target/linux/ramips/rt305x/config-3.3
@@ -113,6 +113,7 @@ CONFIG_RT305X_MACH_PWH2004=y
CONFIG_RT305X_MACH_RT_G32_REVB=y
CONFIG_RT305X_MACH_RT_N10_PLUS=y
CONFIG_RT305X_MACH_SL_R7205=y
+CONFIG_RT305X_MACH_UR_336UN=y
CONFIG_RT305X_MACH_V22RW_2X2=y
CONFIG_RT305X_MACH_W306R_V20=y
CONFIG_RT305X_MACH_W502U=y
diff --git a/target/linux/ramips/rt305x/profiles/upvel.mk b/target/linux/ramips/rt305x/profiles/upvel.mk
new file mode 100644
index 0000000000..fa1c9936d7
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/upvel.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/UPVEL
+ NAME:=UPVEL UR-336UN
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-rt305x-dwc_otg \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/UPVEL/Description
+ Default package set compatible with URVEL router board.
+endef
+$(eval $(call Profile,UPVEL))