aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-17 14:06:13 +0000
committerJohn Crispin <john@openwrt.org>2015-01-17 14:06:13 +0000
commit88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2 (patch)
treea12ec319f40eaf27b5bbf6000bc60429e781f051 /target/linux/ramips/rt305x
parent744298b8a0dc363a802634b5ac5d08e861e65d12 (diff)
downloadupstream-88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2.tar.gz
upstream-88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2.tar.bz2
upstream-88df2bd2ff5aa7b31ce9aaeda25c60e8a9b980b2.zip
ramips: add support for Intenso Memory 2 Move USB 3.0
This adds support for a rt5350-based "portable nas" solution from Intenso. The board comes with 32M RAM and 8M Flash, the built-in HDD is connected/accessible via a usb3.0<->sata bridge VLI VL701. The device has 1 Ethernet port (100M/10M), 1 micro b usb 3.0 socket (for charging the battery, or accessing the hdd directly). Wireless connectivity is provided by the rt5350 SoC [i.e.: 802.11n 1x1 2.4 GHz with a pcb antenna.] Serial, leds, wifi, ethernet and usb are tested and as far as I can tell: they are working fine (tm). Signed-off-by: Christian Lamparter <chunkeey@googlemail.com> SVN-Revision: 44001
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/m2m.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/m2m.mk b/target/linux/ramips/rt305x/profiles/m2m.mk
new file mode 100644
index 0000000000..ea803baa25
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/m2m.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/M2M
+ NAME:=Intenso Memory 2 Move
+ PACKAGES:=\
+ kmod-ledtrig-netdev kmod-ledtrig-timer kmod-leds-gpio \
+ kmod-usb-core kmod-usb2 kmod-usb-storage kmod-scsi-core \
+ kmod-fs-ext4 kmod-fs-vfat block-mount
+endef
+
+define Profile/M2M/Description
+ Package set for Intenso Memory 2 Move USB 3.0
+endef
+
+$(eval $(call Profile,M2M))