aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-16 18:54:42 +0000
committerJohn Crispin <john@openwrt.org>2014-06-16 18:54:42 +0000
commitab390d6c0596ea50564a849f92a7f1ba6096258f (patch)
tree8630223391cfff365e40796d1db92206f0033dda /target/linux/ramips/rt305x/profiles
parent85ca75decd04ed968054bd98b0a5045a24eb2fa7 (diff)
downloadupstream-ab390d6c0596ea50564a849f92a7f1ba6096258f.tar.gz
upstream-ab390d6c0596ea50564a849f92a7f1ba6096258f.tar.bz2
upstream-ab390d6c0596ea50564a849f92a7f1ba6096258f.zip
ramips: restore AWM002-EVB profile in asiarf.mk
In a recent revision (r41177) John Crispin removed the profile for the AsiaRF AWM002 eval board while adding another AsiaRF board. This patch restores AWM002 and also corrects a misspelling and an apparently errant reference to an Allnet ALL0239-3G device. Signed-off-by: Galen Seitz <galens@seitzassoc.com> Signed-off-by: Russell Senior <russell@personaltelco.net> SVN-Revision: 41215
Diffstat (limited to 'target/linux/ramips/rt305x/profiles')
-rw-r--r--target/linux/ramips/rt305x/profiles/asiarf.mk15
1 files changed, 13 insertions, 2 deletions
diff --git a/target/linux/ramips/rt305x/profiles/asiarf.mk b/target/linux/ramips/rt305x/profiles/asiarf.mk
index 2d5231d08e..8aef8a8e4b 100644
--- a/target/linux/ramips/rt305x/profiles/asiarf.mk
+++ b/target/linux/ramips/rt305x/profiles/asiarf.mk
@@ -5,12 +5,23 @@
# See /LICENSE for more information.
#
+define Profile/AWM002EVB
+ NAME:=AsiaRF AWM002-EVB
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+ kmod-i2c-core kmod-i2c-gpio
+endef
+
+define Profile/AWM002EVB/Description
+ Package set for AsiaRF AWM002 Evaluation Board
+endef
+
define Profile/AWAPN2403
- NAME:=AisaRF AWAPN2403
+ NAME:=AsiaRF AWAPN2403
endef
define Profile/AWAPN2403/Description
- Package set for Allnet ALL0239-3G
+ Package set for AsiaRF AWAPN2403 Pocket Router
endef
+$(eval $(call Profile,AWM002EVB))
$(eval $(call Profile,AWAPN2403))