aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-19 14:13:07 +0000
committerJohn Crispin <john@openwrt.org>2014-06-19 14:13:07 +0000
commit9284956ad87d5ed67fbf7246ea68a4f9544312f3 (patch)
treecefab85712bcecc3b075e31cb1f41ea15c85f05d /target/linux/ramips/rt305x/profiles
parent432f7e52dbc55d02ea8336fe5c0d76b04c04b58e (diff)
downloadupstream-9284956ad87d5ed67fbf7246ea68a4f9544312f3.tar.gz
upstream-9284956ad87d5ed67fbf7246ea68a4f9544312f3.tar.bz2
upstream-9284956ad87d5ed67fbf7246ea68a4f9544312f3.zip
ramips: cleanup some rt305x profiles
move both asus boards to asus.mk rename HW5503G profile to HW550-3G to match name in image/Makefile (fixes #16599) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 41271
Diffstat (limited to 'target/linux/ramips/rt305x/profiles')
-rw-r--r--target/linux/ramips/rt305x/profiles/asus.mk (renamed from target/linux/ramips/rt305x/profiles/n13u.mk)12
-rw-r--r--target/linux/ramips/rt305x/profiles/aztech.mk6
-rw-r--r--target/linux/ramips/rt305x/profiles/n10-plus.mk (revision 0)17
3 files changed, 14 insertions, 21 deletions
diff --git a/target/linux/ramips/rt305x/profiles/n13u.mk b/target/linux/ramips/rt305x/profiles/asus.mk
index 6c81722efe..fcf4aa4759 100644
--- a/target/linux/ramips/rt305x/profiles/n13u.mk
+++ b/target/linux/ramips/rt305x/profiles/asus.mk
@@ -1,10 +1,19 @@
#
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+define Profile/RT-N10-PLUS
+ NAME:=Asus RT-N10+
+ PACKAGES:=kmod-leds-gpio wpa
+endef
+
+define Profile/RT-N10-PLUS/Description
+ Package set for Asus RT-N10+.
+endef
+
define Profile/RT-N13U
NAME:=Asus RT-N13U
PACKAGES:=kmod-leds-gpio kmod-rt2800-pci wpad-mini kmod-usb-rt305x-dwc_otg
@@ -14,4 +23,5 @@ define Profile/RT-N13U/Description
Package set for Asus RT-N13U.
endef
+$(eval $(call Profile,RT-N10-PLUS))
$(eval $(call Profile,RT-N13U))
diff --git a/target/linux/ramips/rt305x/profiles/aztech.mk b/target/linux/ramips/rt305x/profiles/aztech.mk
index ab2d8cba2f..63e5d5e294 100644
--- a/target/linux/ramips/rt305x/profiles/aztech.mk
+++ b/target/linux/ramips/rt305x/profiles/aztech.mk
@@ -5,15 +5,15 @@
# See /LICENSE for more information.
#
-define Profile/HW5503G
+define Profile/HW550-3G
NAME:=Aztech HW550-3G
PACKAGES:=\
kmod-usb-core kmod-usb-rt305x-dwc_otg \
kmod-ledtrig-usbdev
endef
-define Profile/HW5503G/Description
+define Profile/HW550-3G/Description
Package set for Aztech HW550-3G
endef
-$(eval $(call Profile,HW5503G))
+$(eval $(call Profile,HW550-3G))
diff --git a/target/linux/ramips/rt305x/profiles/n10-plus.mk (revision 0) b/target/linux/ramips/rt305x/profiles/n10-plus.mk (revision 0)
deleted file mode 100644
index 8c122f75bb..0000000000
--- a/target/linux/ramips/rt305x/profiles/n10-plus.mk (revision 0)
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/RT-N10-PLUS
- NAME:=Asus RT-N10+
- PACKAGES:=kmod-leds-gpio wpa
-endef
-
-define Profile/RT-N10-PLUS/Description
- Package set for Asus RT-N10+.
-endef
-
-$(eval $(call Profile,RT-N10-PLUS))